2 Replies Latest reply on Nov 22, 2002 1:30 AM by dmx

    Tomcat - Jboss interaction, HELP PLEASE !!!

    Luigi Fonti Newbie

      When I installed Jboss-3, I already had Tomcat-4 installed and configured. So, I didn't install the Jboss/Tomcat pair, but Jboss alone.
      Now, every product works correctly, but they don't interact: if a servlet launched by Tomcat tries to recall an EJB managed by Jboss, the bean class is not found.
      The error is:
      ---------------------------------------------------------
      java.lang.NoClassDefFoundError: rubrica/Rubrica
      at java.lang.Class.getDeclaredConstructors0(Native Method)
      at java.lang.Class.privateGetDeclaredConstructors(Class.java:1590)at java.lang.Class.getConstructor0(Class.java:1762)at java.lang.Class.newInstance0(Class.java:276)at java.lang.Class.newInstance(Class.java:259)at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:892)
      at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:658)
      at org.apache.catalina.servlets.InvokerServlet.serveRequest(InvokerServlet.java:408)
      at org.apache.catalina.servlets.InvokerServlet.doGet(InvokerServlet.java:180)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853).....
      ---------------------------------------------------------

      At source level I tried 2 different approachs:
      ---1---
      InitialContext jndiContext = new InitialContext();
      Object ref = jndiContext.lookup("rubrica/Rubrica");
      ---2---
      InitialContext jndiContext = new InitialContext();
      Object ref = jndiContext.lookup ("java:comp/env/ejb/Rubrica");
      ------
      but the result was the same for both. (approach #1 works for a standalone test client application).

      I also tried to copy in the tomcat4/common/lib directory all the jboss/client jar files required to run a test client staldalone application, but the result was the same.
      Help please !!!!!