2 Replies Latest reply on Jan 6, 2003 10:24 AM by David Baillieul

    Configuring an Oracle datasource

    Alphonsus Magno Newbie

      Hi all,
      I've seen a lot of threads on this subject, but none of them answered my question in a definite way. We're using JBoss 3.0.4 and I want to configure an Oracle connection pool named java:/comp/env/jdbc/MyOraclePool. Could anyone tell me which files I should change? I've bought the JBoss Administration book but on this it didn't help much.


        • 1. Re: Configuring an Oracle datasource
          Diogo Catossi Newbie

          Hello Alphonsus,
          I can't believe none of them helped you..... :)
          I'm not using 3.0.4 as we homologated the version 3.0.0 only, though I think it doesn't changed much(about datasources).
          If so, I can help you:
          1st:you can't use java:/comp/env/jdbc/MyOraclePool because /comp/env/ is most likely the java's root environment, instead you will use java:jdbc/MyOraclePool.
          2nd:To use a Pool you have to create a datasource first. Then you have a connection pool embedded to it.
          How? In the folder "JBOSS_HOME\docs\examples\jca" you'll find some .xml files as examples to datasources, get "mysql-service.xml" as your example, copy it to your deploy dir and rename to ex.: oracle-service.xml. Edit it configuring the specific settings such as connection URL, DriverClass, UserName and Password. Also replace all entries named "MySqlDS"(about 3) to "jdbc/MyOraclePool"(or any other name that you'll use to access) and you're done.

          Review the entire XML to see if there's any other change left to be made and, of course, understand it. ;)

          Hope it helps you.

          • 2. Re: Configuring an Oracle datasource
            David Baillieul Newbie

            Making the datasource work is pretty straight forward. The real issue is that id you are using BLOB, etc, you will not have a very positive experience using the Oracle JDBC drivers. We had good luck with third party drivers, but this was an issue.