1 Reply Latest reply on Jan 18, 2003 4:45 AM by Joacim Larsson

    JBoss 3.0.5 built w jdk141 fails

    Joacim Larsson Newbie

      I've tried to upgrade my production server from 3.0.4 to 3.0.5 but it fails.

      I'm using the 3.0.5 version built with jdk141 and I'm deploying on RedHat 8.

      I've copied my 'old' run.sh and jboss_init_redhat.sh from the 3.0.4 dir as well as tried to run with the 3.0.5 versions, but I can't get it working. 3.0.4 works fine however.
      Any clues?
      When I'm starting JBoss I get the following error:

      ================================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /usr/local/jboss/jboss-3.0.5

      JAVA: /usr/java/j2sdk1.4.1_01/bin/java

      JAVA_OPTS: -server -Dprogram.name=run.sh

      CLASSPATH: /usr/local/jboss/jboss-3.0.5/bin/run.jar:/usr/java/j2sdk1.4.1_01/lib/tools.jar

      ================================================================================

      java.lang.ClassNotFoundException: org.jboss.system.server.ServerImpl
      at java.net.URLClassLoader$1.run(URLClassLoader.java:198)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:186)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:241)
      at org.jboss.system.server.ServerLoader.load(ServerLoader.java:224)
      at org.jboss.Main.boot(Main.java:140)
      at org.jboss.Main$1.run(Main.java:381)
      at java.lang.Thread.run(Thread.java:536)