3 Replies Latest reply on Feb 7, 2003 9:51 AM by Tobias Rademacher

    JBoss 3.0.0 and Solaris 9

    Tobias Rademacher Newbie

      Hi guys,

      I have strange problems runnig JBoss on Solaris. Everytime the server is beginning to listen to a port the server seem to hang. The RMIService hangs first. So I supressed it but now the build-in tomcat fails. :-(

      What do you guess could cause this strange problem?

      Any thougts?

      My system:
      Solaris 9
      JBoss 3.0.0-tomcat-4.0.3
      JDK 1.4.1_01

      I started JBoss with a ssh client. Could this be the problem?

      Any hints. I'm run out of ideas, due to the log file does not contains any exceptions. :-(

      Bye & Thx
      Toby

        • 1. Re: JBoss 3.0.0 and Solaris 9
          Tobias Rademacher Newbie

          I configured Jboss now to run without RMI .
          Now embeded Tomcat starts. But this is the last message I got from my JBoss.

          I tried a truss on Jboss and it seems that embeded Tomcat hangs in a loop.

          In Java Bugdatabase I found entry 4694035 (Tomcat hangs). But I'm using 1.4.1_01 and for this VM the bug is close according Sun. Mhm. Any ideas?

          • 2. Re: JBoss 3.0.0 and Solaris 9
            Juha Lindfors Master

            did you set log level to debug? did you try with a different JVM version? did you try with JBoss 3.0.6?

            • 3. Re: JBoss 3.0.0 and Solaris 9
              Tobias Rademacher Newbie

              Hi,

              I tried 3.0.6. This server fails in binding localhost. I guess this is VM version problem. I written a small test program that uses java.net.InetAddress. The programm tries both getByName("localhost"), getLocalHost() and getByName("servername") which all fail with a UnknowHostException.
              As ping works and resolves host names everything works fine. A collegue written a small C pogramm that calls aS olaris system function call in order resolve a host name. This works also. So I guess DNS is configured correctly. Mhm. I will follow your advice and fall back to different VM version say 1.4.0 or 1.4.1 (without _01...).

              Write once debug anyware... a nightmare (The VM and not JBoss).

              Thx
              Toby