2 Replies Latest reply on Mar 13, 2003 5:29 AM by Abyss An

    Pls help me, something about startup jboss

    Abyss An Newbie

      when i startup, the jboss tell me this error:
      09:11:54,520 ERROR [Http11Protocol] Error initializing endpoint
      java.net.BindException: Address in use: JVM_Bind:8080
      at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:270)

      but, i run the command of cmd:netstat, nothing was used the port of 8080, like this:
      Proto Local Address
      TCP Abyss:epmap
      TCP Abyss:microsoft-ds
      TCP Abyss:1028
      TCP Abyss:1030
      TCP Abyss:1099
      TCP Abyss:1476
      TCP Abyss:2701
      TCP Abyss:3248
      TCP Abyss:3280
      TCP Abyss:3287
      TCP Abyss:3288
      TCP Abyss:4444
      TCP Abyss:8083
      TCP Abyss:8090
      TCP Abyss:8091
      TCP Abyss:1038
      TCP Abyss:1720
      TCP Abyss:3278
      TCP Abyss:netbios-ssn
      TCP Abyss:2701

      TCP Abyss:3248

      UDP Abyss:epmap
      UDP Abyss:microsoft-ds
      UDP Abyss:1029
      UDP Abyss:2702
      UDP Abyss:2967
      UDP Abyss:3279
      UDP Abyss:3300
      UDP Abyss:netbios-ns
      UDP Abyss:netbios-dgm
      UDP Abyss:isakmp

      then, i changed the port 8080 to 9090, changed 3 file:
      \JBoss\jboss-3.0.6_tomcat-4.1.18\server\default\deploy\tomcat41-service.xml
      \JBoss\jboss-3.0.6_tomcat-4.1.18\server\default\deploy\http-invoker.sar\META-INF\jboss-servi

      ce.xml
      \JBoss\jboss-3.0.6_tomcat-4.1.18\tomcat-4.1.x\conf\server.xml


      and startup jboss, it was succeed, but when i shutdown it, the port of 9090 was not be set

      free, like this:
      TCP Abyss:9090 TIME_WAIT

      so, i must wait about 10 min and wait the system set the port of 9090 is free, or i shutdown

      and startup my pc.:(

      when i run the cmd:shutdown by itself that was been offered by jboss, it was shutdown the

      port of 8080, not 9090.like this:
      Shutting down server localhost:8080
      Shutdown complete



      so, pls help me and tell me how can i do?