2 Replies Latest reply on Apr 16, 2003 6:30 AM by jkario78

    jboss.home and whitespaces

    jkario78 Newbie

      Trying to start JBoss under Windows 2000. JBoss is installed under directory which has whitespaces in its name. Whitespaces are converted to %20

      C:\Documents and Settings\dummy\JBoss-2.4.10_Tomcat-4.0.6\jboss\bin>run_with_cat
      alina.bat
      JBOSS_CLASSPATH=;/lib/tools.jar;/lib/tools.jar;run.jar;../lib/crimson.jar
      jboss.home = C:\Documents%20and%20Settings\dummy\JBoss-2.4.10_Tomcat-4.0.6\jboss

      Using JAAS LoginConfig: file:/C:/Documents%20and%20Settings/dummy/JBoss-2.4.10_T
      omcat-4.0.6/jboss/conf/catalina/auth.conf
      JBoss release: JBoss-2.4.10 CVSTag=JBoss_2_4_10
      JBoss version: 2.4.10.2002-11-12 21:09:20 PST
      Using configuration "catalina"
      [INFO,root] Installed System.out adapter
      [INFO,root] Installed System.err adapter
      [INFO,root] Started Log4jService, config=file:/C:/Documents and Settings/dummy/J
      Boss-2.4.10_Tomcat-4.0.6/jboss/conf/catalina/log4j.properties

      Later on during startup this leads to.

      [INFO,HypersonicDatabase] Starting
      [INFO,STDOUT] Server.run/init: java.sql.SQLException: File input/output error: C
      :\Documents%20and%20Settings\dummy\JBoss-2.4.10_Tomcat-4.0.6\jboss\db\hypersonic
      \default.properties
      [INFO,HypersonicDatabase] Database started

      Installing JBoss into a different directory (without whitespaces) is not an option. We bundle JBoss with our application and the end user can essentially choose whatever directory he wishes.

      Any workaround for this problem?

      Janne Kario