10 Replies Latest reply on Apr 29, 2003 10:27 AM by Jon Barnett

    Difficulty Setting up on AIX 4.3

    nyquest Newbie

      Hello,

      I'm having problems setting up JBoss on IBM AIX 4.3 with Java 1.3.1. I have also included xerces.jar, xercesimpl, and xmlparserapi.jar for the xml parsing since 1.3.1 doesn't come with xml support.

      I then startup Jboss with run.sh and everythign seems to go fine up to this point where I get this error:

      WARN [NestedThrowable] Duplicate throwable nesting of same base type: class org.jboss.deployment.DeploymentException is assignable from: class org.jboss.deployment.DeploymentException
      15:03:51,687 ERROR [URLDeploymentScanner] Failed to deploy: org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL@de8b80d{ url=file:/install/jboss/jboss-3.2.0_tomcat-4.1.24/server/default/deploy/http-invoker.sar/, deployedLastModified=0 }
      org.jboss.deployment.DeploymentException: exception in init of file:/install/jboss/jboss-3.2.0_tomcat-4.1.24/server/default/deploy/http-invoker.sar/; - nested throwable: (org.jboss.deployment.DeploymentException: Failed to find META-INF/jboss-service.xml)
      at org.jboss.deployment.MainDeployer.init(MainDeployer.java:720)

      I have no idea what this means. I have searched google and this forum for some insight but I have no idea why I get this error. If somebody could please help me that would be great.

      Thanks,
      Ny

        • 1. Re: Difficulty Setting up on AIX 4.3
          afernandez Newbie

          Hi! Try JDK 1.4.x. with JBoss 3.x

          • 2. Re: Difficulty Setting up on AIX 4.3
            nyquest Newbie

            Hello,

            Thanks for the response but the problem is AIX version 4.3 doesn't support JDK 1.4. So switching to 1.4 is not really an option here.

            If there is anybody else that could shed some light on this problem that would be great

            • 3. Re: Difficulty Setting up on AIX 4.3
              Jon Barnett Master

              You may want to try things without your own XML libraries in the classpath. JBoss includes the infrastructure as it has to process XML configuration files - you'll see the xercesimpl.jar in the main JBoss library. It might explain why things fell apart when it tried to read jboss-service.xml. Try it anyway.

              • 4. Re: Difficulty Setting up on AIX 4.3
                nyquest Newbie

                Hi

                I after I removed the xml libraries that I put in myself I noticed that the JBoss Classpath only had run.jar. Also at that point the xml parser wouldn't work anymore. So I figuered there is something wrong with JBoss's classpath. I then added the 2 xml.jar files located in the lib directory to the JBoss classpath and I got the same error.

                My question is are there any other dependencies I should know about? That is, am I missing anything else in the Jboss classpath that I need to make this work?

                Ny

                • 5. Re: Difficulty Setting up on AIX 4.3
                  nyquest Newbie

                  OK here is an update, although nothing is still working but I ran the classpath.sh script to determine the files needed in the JBOSS_CLASSPATH.

                  But I'm still getting the same error of something to do with URLDeploymentScanner i.e. the same error as my very first post.

                  I'm totally lost

                  Ny

                  • 6. Re: Difficulty Setting up on AIX 4.3
                    Jon Barnett Master

                    The startup script for JBoss sets up a static classpath to tools.jar and run.jar. This is all that is needed to boostrap JBoss. JBoss will load all classes in archives located in its topmost lib into its runtime environment to further the start up process and get the core JBoss kernel up and running (e.g. ${JBOSS_HOME}/lib). It will then load classes from the instance lib into its runtime environment so it can start the various instance specific services (e.g. ${JBOSS_HOME}/server/default/lib).

                    Remove any other specific jars from your classpath before starting JBoss.

                    Post your boot.log and server.log as attachments here so we can view them. Someone should then be able to have an idea of how far things are getting.

                    • 7. Re: Difficulty Setting up on AIX 4.3
                      nyquest Newbie

                      jonlee,

                      I really appreciate all the help you have supplied for me. I have one question before I try this again.

                      When I first extracted JBoss from download and ran "run.sh" It gave me an error saying could not find some xml factory. To let you know the environment, I do not have a CLASSPATH or a JBOSS_CLASSPATH envirnment variable setup so everything is just "straight out of the box" for JBoss. So I then preceided to add the XML libraries into the CLASSPATH I then did not get that error but I got the error I posted here.

                      So what I don't get is you're telling me that I don't need anything in my classpaths or jboss_classpath?

                      I will try but I'm not sure how its goign to work if i'm running Java 1.3.1 with no XML parsing capabilities

                      Ny

                      • 8. Re: Difficulty Setting up on AIX 4.3
                        Jon Barnett Master

                        There should be no requirement for any additionals but we need to establish that first by actually sighting the errors coming up. We've run JBoss with the JDK from WAS 5.0 in AIX without any issues. I assume you have the IBM JDK?

                        Essentially, the only thing you may need is to configure JAVA_HOME. You can read through the run.sh script. It isn't that complex so you can assure yourself of what is happening.

                        When you start running the script, you probably should get something like this:

                        ================================================================================

                        JBoss Bootstrap Environment

                        JBOSS_HOME: /usr/local/JBoss-3.2.0

                        JAVA: /usr/local/j2sdk1.4.1_01/bin/java

                        JAVA_OPTS: -server -Dprogram.name=run.sh

                        CLASSPATH: /usr/local/JBoss-3.2.0/bin/run.jar:/usr/local/j2sdk1.4.1_01/lib/too
                        ls.jar

                        ================================================================================

                        In this case, it is from a Linux boxen. Unfortunately, we don't currently have any book-ins to the IBM virtual labs so I can't walk this one through with you.

                        As you can see, there is nothing special in the classpath. JBoss should be pretty much self-contained in terms of bootstrapping itself to life.

                        JBoss will load up the classes in its lib directories automagically.

                        • 9. Re: Difficulty Setting up on AIX 4.3
                          nyquest Newbie

                          Hey,

                          Yeah thats what I get but some different things. One thing is that you're running 1.4.1 so there isn't anything you really need because I was able to get it running on 1.4.1 too (on my Windows machine). Secondly because we're running AIX 4.3 it only supports IBM JDK 1.3.1 and nothign higher and thats why I can't use 1.4.1. I also believe that WAS 5.0 comes with 1.4.1 natively installed so....that could explain why you were able to run JBoss no problem WAS.

                          I guess I'll have to try running a older version of JBoss but I was wondering is it possible to run Sun's Version of Java on a AIX machine.

                          I think I'm just gogin to have to give up on this JBoss 3.2. =\

                          Ny

                          • 10. Re: Difficulty Setting up on AIX 4.3
                            Jon Barnett Master

                            No, the example from Linux was just to give you an idea of the way the environment should be set up. You would substitute the patterns for your environment accordingly. The important thing to see was the classpath - it just had the run.jar and the tools.jar from your Java distribution.

                            WAS 5.0 currently comes with IBM JDK 1.3.1 (note, not Sun JDK 1.3.1). I don't believe that WAS 5.0 will ship with an IBM architected JDK 1.4.1 until later in the year. So we were running JBoss with IBM JDK 1.3.1.