5 Replies Latest reply on May 16, 2003 2:13 AM by danielagatt

    JBoss Configuration for ECPerf

    danielagatt Newbie

      Hi,

      Is there any documentation out there on how to configure ECPerf 1.1 for JBoss 3.2.0??

      I'm trying to follow ECPerf's docs but I am stuck in the step "Build and Deployment Process" where I have to run "ant -f ri.xml". I have renamed ri.xml to jboss.xml and I tried to adapt it to our environment. It simply does not work! Since the document only describes setup steps for J2EE RI I am finding it practically impossible to adapt since I am still very new to JBoss.

      Now I've tried to copy ecperf.ear and emulator.ear to JBoss's deploy directory but I'm getting the errors shown in the file attached.

      Can someone pleez help??!!

      Thanks in advance

      Daniela

        • 1. Re: JBoss Configuration for ECPerf
          Jon Barnett Master

          You can use this as a starting point if you haven't already. It refers to 2.4.x of JBoss so just adjust to use the 3.2.x datasource/jdbc configuration.

          See if you can get away with not performing the Xerces installation in this guide. The deploy directory has changed in JBoss 3.2.x so take the meaning rather than following the directory instructions literally. The same with log4j configuration.

          Don't bother about the invoker step.

          http://www.cmis.csiro.au/adsat/JBossECPerfREADME.htm

          I haven't tried this with the current distribution but it shouldn't be too difficult with these instructions as a guide.

          • 2. Re: JBoss Configuration for ECPerf
            danielagatt Newbie

            I am actually trying to use the document you suggested. I'm getting the following error when I configure the datasource in jboss-service.xml as follows:


            ECperf
            org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl
            jdbc:oracle:thin:@deimos:1523:ecperf
            ecperf
            ecperf
            50
            10000
            TRANSACTION_READ_COMMITTED


            Error returned:

            0va.lang.ClassNotFoundException: org.jboss.jdbc.XADataSourceLoader8:19:42,112 WARN [ServiceConfigurator] Failed to comp
            lete install
            java.lang.ClassNotFoundException: org.jboss.jdbc.XADataSourceLoader
            at java.net.URLClassLoader$1.run(URLClassLoader.java:198)

            • 3. Re: JBoss Configuration for ECPerf
              danielagatt Newbie

              Hi,

              THks for yr feedback.

              I was actually using the document you suggested but it is very misleading since it described ECPerf 1.0 and not 1.1.

              I tried to configure the datasource as it suggests in jboss-service.xml as follows


              ECperf
              org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl
              jdbc:oracle:thin:@deimos:1523:ecperf
              ecperf
              ecperf
              50
              10000
              TRANSACTION_READ_COMMITTED


              But I'm getting the following error on startup of JBoss - JBoss even simply shuts down after getting this error.

              08:19:38,379 INFO [MainDeployer] Starting deployment of package: file:/home/apps/jboss-3.2.0_tomcat-4.1.24/server/defau
              lt/conf/jboss-service.xml
              08:19:39,382 INFO [SARDeployer] looking for nested deployments in : file:/home/apps/jboss-3.2.0_tomcat-4.1.24/server/de
              fault/conf/jboss-service.xml
              08:19:42,112 WARN [ServiceConfigurator] Failed to complete install
              java.lang.ClassNotFoundException: org.jboss.jdbc.XADataSourceLoader
              at java.net.URLClassLoader$1.run(URLClassLoader.java:198)
              at java.security.AccessController.doPrivileged(Native Method)
              at java.net.URLClassLoader.findClass(URLClassLoader.java:186)

              Cheers
              Daniela

              • 4. Re: JBoss Configuration for ECPerf
                danielagatt Newbie

                Hi,

                THks for yr feedback.

                I was actually using the document you suggested but it is very misleading since it described ECPerf 1.0 and not 1.1.

                I tried to configure the datasource as it suggests in jboss-service.xml as follows


                ECperf
                org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl
                jdbc:oracle:thin:@deimos:1523:ecperf
                ecperf
                ecperf
                50
                10000
                TRANSACTION_READ_COMMITTED


                But I'm getting the following error on startup of JBoss - JBoss even simply shuts down after getting this error.

                08:19:38,379 INFO [MainDeployer] Starting deployment of package: file:/home/apps/jboss-3.2.0_tomcat-4.1.24/server/defau
                lt/conf/jboss-service.xml
                08:19:39,382 INFO [SARDeployer] looking for nested deployments in : file:/home/apps/jboss-3.2.0_tomcat-4.1.24/server/de
                fault/conf/jboss-service.xml
                08:19:42,112 WARN [ServiceConfigurator] Failed to complete install
                java.lang.ClassNotFoundException: org.jboss.jdbc.XADataSourceLoader
                at java.net.URLClassLoader$1.run(URLClassLoader.java:198)
                at java.security.AccessController.doPrivileged(Native Method)
                at java.net.URLClassLoader.findClass(URLClassLoader.java:186)

                Cheers
                Daniela

                • 5. Re: JBoss Configuration for ECPerf
                  danielagatt Newbie

                  Hi,

                  Thks for yr feedback. I'm the same user as danielagatt but I had to re-register coz I forgot my password.

                  I was actually making use of the document that you suggested but it is actually quite confusing because it described ecperf 1.0 and not 1.1

                  I have tried to configure the data source in jboss-service.xml as follows:


                  ECperf
                  org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl
                  jdbc:oracle:thin:@deimos:1523:ecperf
                  ecperf
                  ecperf
                  50
                  10000
                  TRANSACTION_READ_COMMITTED


                  But, I'm getting the following error:

                  08:19:38,379 INFO [MainDeployer] Starting deployment of package: file:/home/apps/jboss-3.2.0_tomcat-4.1.24/server/defau
                  lt/conf/jboss-service.xml
                  08:19:39,382 INFO [SARDeployer] looking for nested deployments in : file:/home/apps/jboss-3.2.0_tomcat-4.1.24/server/de
                  fault/conf/jboss-service.xml
                  08:19:42,112 WARN [ServiceConfigurator] Failed to complete install
                  java.lang.ClassNotFoundException: org.jboss.jdbc.XADataSourceLoader
                  at java.net.URLClassLoader$1.run(URLClassLoader.java:198)
                  at java.security.AccessController.doPrivileged(Native Method)
                  at java.net.URLClassLoader.findClass(URLClassLoader.java:186)

                  What am I doing wrong?

                  Rgds
                  Daniela