0 Replies Latest reply on May 26, 2003 12:52 PM by cmhwebster

    JBoss 3.0.4 and JDK 1.3.1 or 1.4.0

    cmhwebster Newbie

      I'm just getting started with JBoss 3.0.4 (Jetty) on Win2K. I have been using JDK 1.4.0 by default, but when I start JBoss with its default configuration set, I get some MBean failures: jboss-local-jdbc, jboss-xa and jms-ra. The stack trace says this is due to a java.lang.IllegalAccessException where java.lang.reflect.Method cannot access private members of org.jboss.resource.RARMetaData.

      I can still access jmx-console, though I don't know if this is working properly.

      If I change my JDK to 1.3.1, then JBoss starts fine, without these errors. Problem is that I want to keep using JDK 1.4, so does anybody know why I get these errors with JDK 1.4.0, and what I cand o to fix them?

      Thanks,
      Chris