5 Replies Latest reply on May 29, 2003 12:58 PM by Raja

    jmx-console - unable to compile

    gls Newbie

      None of my .ear files will run - I get the HTTP ERROR 500 - Unable to compile error for every one of them, including the jmx-console. Any ideas?

        • 1. Re: jmx-console - unable to compile
          Harald Gliebe Novice

          Hard to tell from the information your giving. Is the JAVA_HOME environment variable poiniting to a valid JDK ? The jsp compiler needs $JAVA_HOME/lib/tools.jar to compile JSPs.

          Regards,

          Harald

          • 2. Re: jmx-console - unable to compile
            gls Newbie

            Thanks for your response, Harald. I checked - JAVA_HOME is set correctly and I have verified that tools.jar is in the lib directory.

            What other information would be helpful? While I'm trying to debug this, I wrote one app that consisted of a JSP page (only HTML ) and an HTML page that worked together and put it up - same issue. The HTML exception reads "Unable to compile jsp". The JBoss log shows "class not found exception for index_jsp".

            • 3. Re: jmx-console - unable to compile
              Raja Master

              r u using JDK 1.4? try switching to 1.3
              I remember having this problem with Just tomcat on a solaris box with 1.4

              • 4. Re: jmx-console - unable to compile
                gls Newbie

                Thanks for the response.

                I tried setting JAVA_HOME to our 1.3.1 installation. Still didn't work. Here is the JBoss Log entry:

                08:19:11,437 WARN [jbossweb] WARNING: Exception for /jmx-console/index.jsp
                java.lang.ClassNotFoundException: org.apache.jsp.index_jsp
                at org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:209)
                at org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:131)
                at org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:504)


                Here is the IE and Netscape entry

                HTTP ERROR: 500 Unable to compile class for JSP
                RequestURI=/jmx-console/index.jsp





                • 5. Re: jmx-console - unable to compile
                  Raja Master

                  The index_jsp.java would be under JBoss_Home/tomcat-4.1.x/work/Mainengine/localhost/<ur app>.
                  Check if there is a indeX_jsp.class in teh same directory.

                  I would also try removing the whole work directory and starting the server back. It will be recreated anyway the next time tomcat starts.