4 Replies Latest reply on Dec 18, 2003 11:06 AM by John C. Kendall

    jBoss 3.2.1 hangs on startup on linux

    jbrosenberg Newbie

      Ok,

      I just copied the 3.2.1 distribution from NT, where
      it worked fine, to a Debian Linux 2.2.17 machine...

      Now it hangs on startup with either the all or default server configs, and this is the last thing it displays:

      04:05:02,813 INFO [WebService] Creating

      Not surprisingly, the minimal config starts up fine...

      Anyway, any ideas what I need to do to unhang this startup?

      Do I need to enable something on my linux system?

        • 1. Re: jBoss 3.2.1 hangs on startup on linux
          Bernd Zeitler Expert

          Probably the permissions the (JBoss) user is running on linux.

          Greetings,
          Frito

          • 2. Re: jBoss 3.2.1 hangs on startup on linux
            John Jennings Newbie

            I had this same problem... it seems that WebService creation hangs when the server doesn't have a fully qualified inet name (i.e. nodename. domainname) when viewed from the localhost on which it is running.

            I'm working with an Xpc form-factor machine that I move back and forth between home and work... I found that my inet name wasn't fully qualified in one of the environments (nodename only without domainname) and that is where I experienced this problem.

            A quick (and possibly dirty) solution is to insure that you have an entry for your server (with both nodename. domainname and alias of nodename only) in your /etc/hosts file (on the server).

            In any case, JBoss shouldn't just hang forever... we should be seeing some error info displayed here.

            • 3. Maybe Bug: also in jboss-4.0.0DR1_tomcat-4.1.24
              senador Newbie

              I've been trying to run jboss on my mandrake 9.1. My default config doesn't have a fully qualified name, only 127.0.0.1 localhost in /etc/hosts.

              In Jboss 3.2.1 it hags the way previously described.
              In Jboss 4.0.0. it hangs forever (or at my patience limit :-)) at the message:

              20:19:48,065 INFO [Server] Core system initialized
              20:19:48,119 INFO [MainDeployer] Starting deployment of package: file:/opt/jboss-4.0.0DR1_tomcat-4.1.24/server/default/conf/jboss-service.xml
              20:19:48,168 INFO [SARDeployer] looking for nested deployments in : file:/opt/jboss-4.0.0DR1_tomcat-4.1.24/server/default/conf/jboss-service.xml

              Both problems in default configuration, and both solved by adding any fully qualified namein /etc/hosts.

              • 4. Re: jBoss 3.2.1 hangs on startup on linux
                John C. Kendall Newbie

                Actually, you just have to make sure that whatever the "hostname" command returns is listed in your /etc/hosts under 127.0.0.1.

                For example, on my machine:
                $ hostname
                merlin

                /etc/hosts:
                127.0.0.1 localhost merlin someOtherAlias

                Regards,
                jck