1 Reply Latest reply on Jun 23, 2003 2:34 PM by Raja

    Mulitple Jboss 3x instances help please

    susan.deaves Newbie

      I have set up a second server directory as a copy of default under under the server. I have edited the jboss-service.xml in one of these to run on 3 non-default ports (1099;4444;8083 to 51099;54444;58083). I can run both of these servers from the .run command without error but get a JVM bind error when I try to run them simultaneously:-

      16:34:02,739 INFO [testDurableTopic] Started
      16:34:02,749 INFO [testQueue] Starting
      16:34:02,759 INFO [testQueue] Bound to JNDI name: queue/testQueue
      16:34:02,769 INFO [testQueue] Started
      16:34:02,779 INFO [InterceptorLoader] Starting
      16:34:02,789 INFO [InterceptorLoader] Started
      16:34:02,799 INFO [Invoker] Starting
      16:34:02,809 INFO [Invoker] Started
      16:34:02,819 INFO [JVMServerILService] Starting
      16:34:02,889 INFO [JVMServerILService] Started
      16:34:02,899 INFO [RMIServerILService] Starting
      16:34:03,059 INFO [RMIServerILService] Started
      16:34:03,069 INFO [OILServerILService] Starting
      16:34:03,089 ERROR [OILServerILService] Starting failed
      java.net.BindException: Address already in use: JVM_Bind
      at java.net.PlainSocketImpl.socketBind(Native Method)
      at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:331)
      at java.net.ServerSocket.bind(ServerSocket.java:318)
      at java.net.ServerSocket.(ServerSocket.java:185)
      at javax.net.DefaultServerSocketFactory.createServerSocket(DashoA6275)
      at org.jboss.mq.il.oil.OILServerILService.startService(OILServerILServic
      at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:1
      at sun.reflect.GeneratedMethodAccessor7.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBea

      I am unlclear which port is causing the problem.
      Is there another port somewhere that needs setting, or a domain setting or something else that I have missed?