0 Replies Latest reply on Jul 2, 2003 3:38 AM by Stephanie Tam

    Repeated process - DocumentBuilderFactory

    Stephanie Tam Newbie

      I have been running JBoss 2.4.4 with catalina for more than a year on Linux 7.2. JDK version is 1.3.1_02. All of a sudden, the Linux is repeated trying to activate this process:

      10087 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10088 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10089 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10090 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10091 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10092 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10093 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10094 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10095 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10096 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10097 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10098 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10099 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10100 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10101 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a
      10102 ? S 0:00 /usr/java/jdk1.3.1_03/bin/i386/native_threads/java -Djavax.xml.parsers.DocumentBuilderFactory=org.a

      and it throws these errors every time I start the service run_with_catalina.sh --

      [INFO,EmbeddedCatalinaServiceSX] StandardHost[localhost]: MAPPING configuration error for request URI
      [ERROR,EmbeddedCatalinaServiceSX] HttpProcessor[8080][3] process.invoke
      java.lang.NullPointerException
      at org.apache.catalina.valves.ErrorDispatcherValve.status(ErrorDispatcherValve.java:280)
      at org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:180)
      at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:564)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:170)
      at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:564)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:163)
      at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:566)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)
      at org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:1011)
      at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1106)
      at java.lang.Thread.run(Thread.java:479)

      What is going on here? How can it be working for a year and all of a sudden stops working? Any input is greatly appreciated. THank you.