2 Replies Latest reply on Sep 26, 2003 2:23 PM by kbutler

    unpackWARs in Tomcat

    kbutler Newbie

      Has anyone gotten this to work?

      I'm running jboss3.2.1 with the bundled tomcat 4.1.24.

      I took config elements from another Tomcat4 installation I have and have tried various combinations in my jbossweb-tomcat.sar/META-INF/jboss-service.xml -- no luck yet.

      Here's the Host tag that I modified (note that the debug="1" worked great!! but didn't help). Everything else in that file is as shipped:





      Anybody figure out the magic?
      Kent

        • 1. Re: unpackWARs in Tomcat
          kenevel Newbie

          Hi mate,

          Did you find out how to make this work? If you did, would you mind letting me know, as we're going through a similar issue right now.

          Cheers

          Mike

          kenevel@hotmail.com

          • 2. Re: unpackWARs in Tomcat
            kbutler Newbie

            Mike -
            Well what I have to tell you may not help, but here's the route I took and am satisfied with.

            Originally I was familiar with Tomcat so was heading in that direction. I messed around trying to get this to work, and eventually found something on the web indicating that this was broken in Tomcat.

            But after more investigation into the differences between Jetty and Tomcat, I concluded that Jetty performed on an equal (and probably better) level than Tomcat, and its design & development seemed more focused and better architected from its inception. As far as I have seen it's very J2EE1.3/Servlet2.3 compliant, which are my base reqs.

            So I went with Jetty, which has really been well-behaved. I haven't load-tested it yet, but the load-test data I saw on it was sufficient for me, and it's been around for some time now, at least as long as Tomcat as I recall.

            That's my story, no regrets. If you need any Jetty tips I can offer what I know.
            Cheers -
            Kent