3 Replies Latest reply on Jul 28, 2003 7:19 PM by Jon Barnett

    jboss stops running after a few hours on linux

    davem Newbie

      Hi,

      I'm running Jboss 3.2.1 and Tomcat 4.1.24 on linux. After a few hours, jboss stops running. I think the problem has to do with the fact that jboss needs to run as a background process. I've run Jboss as ./run.sh -c projectname& to make it run in the background and I've also edited my run.sh file to make it run in the background.

      I don't have this problem with Jboss 2.4 and I edited my run.sh file in the same manner.

      One thing that is very curious is that if I run Jboss like
      ./run.sh -c projectname&, once jboss has started, it says the background process has completed. I think this is because the run.sh script has completed.

      When I run Jboss using my run.sh script and in the file I use the "&" to send the process to the background, Jboss just stops running after a few hours. Typing in "jobs" reveals no background jobs.

      The last part of my run.sh file looks like this:

      # Execute the JVM
      $JAVA $JAVA_OPTS \
      -classpath "$JBOSS_CLASSPATH" \
      org.jboss.Main "$@" &


      Any help would be GREATLY appreciated.

      Thanks in advance,

      Dave