4 Replies Latest reply on Jul 30, 2003 1:41 PM by lian68616888

    apache2.0 with jboss3.2

    lian68616888 Newbie

      I try to connect apache2 to jboss3.2 with mod_jk2.dll under win2000 env, and I can not make it work, please somebody help. I got some error information in the error.log of apache :No worker file and no worker options in httpd.conf
      use JkWorkerFile to set workers

      [Mon Jul 28 14:42:11 2003] [notice] Parent: Created child process 1684
      No worker file and no worker options in httpd.conf
      use JkWorkerFile to set workers

      [Mon Jul 28 14:42:11 2003] [notice] Child 1684: Child process is running
      [Mon Jul 28 14:42:11 2003] [notice] Child 1684: Acquired the start mutex.
      [Mon Jul 28 14:42:11 2003] [notice] Child 1684: Starting 250 worker threads.
      [Mon Jul 28 14:42:58 2003] [error] [client 127.0.0.1] File does not exist: E:/Apache Group/Apache2/htdocs/quote
      [Mon Jul 28 14:45:20 2003] [notice] Parent: Received shutdown signal -- Shutting down the server.
      [Mon Jul 28 14:45:20 2003] [notice] Child 1684: Exit event signaled. Child process is ending.
      [Mon Jul 28 14:45:21 2003] [notice] Child 1684: Released the start mutex
      [Mon Jul 28 14:45:22 2003] [notice] Child 1684: Waiting for 250 worker threads to exit.
      [Mon Jul 28 14:45:22 2003] [notice] Child 1684: All worker threads have exited.
      [Mon Jul 28 14:45:22 2003] [notice] Child 1684: Child process is exiting
      [Mon Jul 28 14:45:22 2003] [notice] Parent: Child process exited successfully.
      [Mon Jul 28 14:45:29 2003] [notice] Parent: Created child process 128
      No worker file and no worker options in httpd.conf
      use JkWorkerFile to set workers

      [Mon Jul 28 14:45:29 2003] [notice] Child 128: Child process is running
      [Mon Jul 28 14:45:29 2003] [notice] Child 128: Acquired the start mutex.
      [Mon Jul 28 14:45:29 2003] [notice] Child 128: Starting 250 worker threads.

      and my workers2.properties file is:

      #define the shared memory file
      [shm]
      file=E:/Apache Group/Apache2/logs/jk2.shm
      size=1048576

      # Example socket channel, override port and host.
      # Define teh communication channel
      [channel.socket:localhost:8009]
      tomcatId=localhost:8009

      # define the worker
      [ajp13:localhost:8009]
      channel=channel.socket:localhost:8009

      # Uri mapping
      [uri:/quote/*]
      worker=ajp13:localhost:8009

      # Define the comunication channel
      [channel.jni:jni]
      info=The jni channel, used if tomcat is started inprocess


      [config:]
      file=E:/Apache Group/Apache2/conf/workers2.properties
      debug=0
      debugEnv=0

      # Define the parameters for the Java Virtual Machine
      [vm:]
      info=Parameters used to load a JVM in the server process
      OPT=-Djava.class.path=e:/jboss-3.2.1_tomcat-4.1.24/server/default/jbossweb-tomcat.sar
      OPT=-Dtomcat.home=e:/jboss-3.2.1_tomcat-4.1.24
      OPT=-Dcatalina.home=e:/jboss-3.2.1_tomcat-4.1.24
      OPT=-Xmx128M

      # JNI worker startup handler
      [worker.jni:onStartup]
      info=Command to be executed by the VM on startup. This one will start tomcat.
      class=org/apache/jk/apr/TomcatStarter
      ARG=start
      stdout=E:/Apache Group/Apach2/logs/stdout.log
      stderr=E:/Apache Group/Apache2/logs/stderr.log

      # JNI worker shutdown handler
      [worker.jni:onShutdown]
      info=Command to be executed by the VM on shutdown. This one will stop tomcat.
      class=org/apache/jk/apr/TomcatStarter
      ARG=stop

      # Uri mapping
      [uri:/quote]
      info=Example webapp in the default context.
      context=/quote

      [uri:/equote/*]
      info=Map the whole webapp

      and my jk2.properites file are :
      ## THIS FILE MAY BE OVERRIDEN AT RUNTIME. MAKE SURE TOMCAT IS STOPED
      ## WHEN YOU EDIT THE FILE.

      ## COMMENTS WILL BE _LOST_

      ## DOCUMENTATION OF THE FORMAT IN JkMain javadoc.

      # Override the default port for the socketChannel
      # channelSocket.port=8019
      # Default:
      # channelUnix.file=${jkHome}/work/jk2.socket
      # Just to check if the the config is working
      shm.file=E:/Apache Group/Apache2/logs/jk2.shm
      size=10485760

      # In order to enable jni use any channelJni directive
      channelJni.disabled = 0
      # And one of the following directives:

      # apr.jniModeSo=/opt/apache2/modules/mod_jk2.so

      #set the desired handler list
      handler.list=apr,request,channelJni

      # If set to inprocess the mod_jk2 will Register natives itself
      # This will enable the starting of the Tomcat from mod_jk2

      apr.jniModeSo=inprocess

      and in the httpd.conf I already load the module of jk2,


      please help to figure out what is wrong with my configuration. Thanks