3 Replies Latest reply on Sep 10, 2003 2:11 PM by aalmero

    deployment problem on Solaris?

    tstrawhacker Newbie

      Hello --

      I'm deploying a war file that works fine under Windows 2000 Pro, but fails under Solaris 8. It fails with a message saying that JBoss could not start deployment of my war file because of a NoClassDefFoundError, then it lists the class, then JBoss continues its startup.

      When I point my browser to the war file's URL, the application starts up, but then throws a NoClassFound exception on the same class. I've verified that this class is present in a jar file contained in the war file, as are a number of other classes that are in the same jar file (inside the war file) that DO execute correctly.

      I see no difference between the jar file entry of the class that JBoss is complaining about, and the entries of other classes that seem to work fine. This is the same war file that works fine with JBoss under Windows, after a binary-mode ftp to Solaris.

      What could be going wrong?

      Thanks, Tim

        • 1. Re: deployment problem on Solaris?
          Jon Barnett Master

          Have you checked that the directory listing /structure for the WAR maintains case-sensitivity? Sometimes it doesn't follow through from the packing and runs fine on Windows. For example WEB-INF/classes/myclass.class gets packed as web-inf/classes/myclass.class. Generally, it is recommended to check with jar -tf myapp.war and manually check that listing does not bring up something unexpected.

          Give that a try and if still no luck, let the folks here know. They might be able to think of some other problem that would explain the difference between the two environments.

          • 2. Re: deployment problem on Solaris?
            tstrawhacker Newbie

            Thanks for the response, jonlee! Case sensitivity was maintained (I built with Ant), the problem turned out to be something else. I'm still not up and running on Solaris, but I'm past that issue. Thanks again!

            • 3. Re: deployment problem on Solaris?
              aalmero Newbie

              i did not have any problems deploying war files on jboss in solaris, even ear files are working fine. my development env is window2000 and deplyed the application in solaris8.

              i suggest u checked the directory structure or add classpath in ur MANIFEST file