11 Replies Latest reply on Oct 15, 2003 10:55 AM by Lamouret

    can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help!!!

    zxc Newbie

      In sco unixware7.1.1 I install j2sdk1.3.1_08 on opt/java2-1.3.1, and jboss-3.2.1-tomcat4.1.24 down from the sourceforge jboss projects. When all ready , I run the ./run.sh command,the program runs ,but when deploy jboss-service.xml (kernal) file ,the jboss shutdown. then message is following:
      //**************************************
      19:47:08,490 INFO [MainDeployer] Starting deployment of package: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/conf/jboss-service.xml
      19:47:08,510 ERROR [Server] Failed to start
      java.lang.AbstractMethodError: org/jboss/deployment/SubDeployerSupport.accepts
      at org.jboss.deployment.MainDeployer.findDeployer(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.init(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:613)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:597)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java, Compiled Code)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:549)
      at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java, Compiled Code)
      at $Proxy6.deploy(Unknown Source)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java, Compiled Code)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:272)
      at org.jboss.Main.boot(Main.java, Compiled Code)
      at org.jboss.Main$1.run(Main.java:388)
      at java.lang.Thread.run(Thread.java:479)
      java.lang.AbstractMethodError: org/jboss/deployment/SubDeployerSupport.accepts
      at org.jboss.deployment.MainDeployer.findDeployer(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.init(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:613)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:597)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java, Compiled Code)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:549)
      at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java, Compiled Code)
      at $Proxy6.deploy(Unknown Source)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java, Compiled Code)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:272)
      at org.jboss.Main.boot(Main.java, Compiled Code)
      at org.jboss.Main$1.run(Main.java:388)
      at java.lang.Thread.run(Thread.java:479)
      19:47:08,520 INFO [Server] JBoss SHUTDOWN: Undeploying all packages
      19:47:08,520 INFO [MainDeployer] Undeploying file:/web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/conf/jboss-service.xml
      19:47:08,530 ERROR [MainDeployer] Undeployment cleanup failed: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/conf/jboss-service.xml
      java.lang.NullPointerException
      at org.jboss.deployment.DeploymentInfo.cleanup(DeploymentInfo.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.destroy(MainDeployer.java, Compiled Code)
      at org.jboss.deployment.MainDeployer.undeploy(MainDeployer.java:481)
      at org.jboss.deployment.MainDeployer.shutdown(MainDeployer.java:368)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java, Compiled Code)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:549)
      at org.jboss.system.server.ServerImpl$ShutdownHook.shutdownDeployments(ServerImpl.java:808)
      at org.jboss.system.server.ServerImpl$ShutdownHook.shutdown(ServerImpl.java:783)
      at org.jboss.system.server.ServerImpl$ShutdownHook.run(ServerImpl.java:771)
      19:47:08,530 INFO [MainDeployer] Undeployed 1 deployed packages
      19:47:08,530 INFO [Server] Shutting down all services
      Shutting down

      //*********************************
      what's wrong with it? I create a helloworld ,java file ,and compile on unixware, run it ,very well. But how can I for this situation? how can I run the jboss successful?(I run the jboss on windows platform very well), is the problem attribute to jdk or jboss?
      following is the jboss begin runing infomation:
      //*************************************
      ================================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /web/setup/jboss-3.2.1_tomcat-4.1.24

      JAVA: /opt/java2-1.3.1/bin/java

      JAVA_OPTS: -Dprogram.name=run.sh

      CLASSPATH: /web/setup/jboss-3.2.1_tomcat-4.1.24/bin/run.jar:/opt/java2-1.3.1/lib/tools.jar

      ================================================================================

      19:47:07,980 INFO [Server] Starting JBoss (MX MicroKernel)...
      19:47:07,980 INFO [Server] Release ID: JBoss [WonderLand] 3.2.1 (build: CVSTag=JBoss_3_2_1 date=200305041533)
      19:47:07,980 INFO [Server] Home Dir: /web/setup/jboss-3.2.1_tomcat-4.1.24
      19:47:07,980 INFO [Server] Home URL: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/
      19:47:07,980 INFO [Server] Library URL: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/lib/
      19:47:07,990 INFO [Server] Patch URL: null
      19:47:07,990 INFO [Server] Server Name: default
      19:47:07,990 INFO [Server] Server Home Dir: /web/setup/jboss-3.2.1_tomcat-4.1.24/server/default
      19:47:07,990 INFO [Server] Server Home URL: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/
      19:47:07,990 INFO [Server] Server Data Dir: /web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/data
      19:47:07,990 INFO [Server] Server Temp Dir: /web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/tmp
      19:47:07,990 INFO [Server] Server Config URL: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/conf/
      19:47:07,990 INFO [Server] Server Library URL: file:/web/setup/jboss-3.2.1_tomcat-4.1.24/server/default/lib/
      19:47:07,990 INFO [Server] Root Deployemnt Filename: jboss-service.xml
      19:47:07,990 INFO [Server] Starting General Purpose Architecture (GPA)...
      19:47:08,200 INFO [ServerInfo] Java version: 1.3.1_08,The SCO Group, Inc.
      19:47:08,200 INFO [ServerInfo] Java VM: Classic VM SCO-UNIX-J2SE-1.3.1_08:*FCS*:20030801,The SCO Group, Inc.
      19:47:08,200 INFO [ServerInfo] OS-System: UnixWare 7.1.1,IA32
      19:47:08,250 INFO [ServiceController] Controller MBean online
      19:47:08,300 INFO [MainDeployer] Creating
      19:47:08,330 INFO [MainDeployer] Created
      //***********************************

      help,help,help????

        • 1. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
          zxc Newbie

          Any body give me some advice? Any suggestion are appreciated!(I am online waiting ur help)

          • 2. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
            Jon Barnett Master

            Try building JBoss from the source using your JDK. There have been reports that some people have had problems with the standard binary distribution with certain 1.3.x JDKs.

            • 3. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
              zxc Newbie

              Yeah,I do it, but the result made me disappoint. build fail on unixware jdk1.3.1_08 which release at Aug 1 2003.
              the following is the result:
              //*************************************
              $ ksh build.sh
              Searching for build.xml ...
              Buildfile: /web/jboss-3.2.1-src/build/build.xml
              Trying to override old definition of task property

              _buildmagic:init:

              _buildmagic:init:local-properties:

              _buildmagic:init:buildlog:

              configure:
              [echo] groups: default
              [echo] modules: common,jmx,system,j2ee,naming,transaction,server,security,messaging,connector,cluster,jetty,varia,jboss.net,iiop,management,catalina,console

              init:

              _buildmagic:modules:most:
              [execmodules]
              [execmodules] ======================================================================
              [execmodules] == Executing 'most' in module 'common'...
              [execmodules] ==

              _buildmagic:init:

              configure:

              init:

              compile-mbean-sources:
              [execmodules] (XDocletMain.start ? ) Running
              [execmodules] INFO: Some classes refer to other classes that were not found among the sources or on the classpath.
              [execmodules] (Perhaps the referred class doesn't exist? Hasn't been generated yet?)
              [execmodules] The referring classes do not import any fully qualified classes matching these classes.
              [execmodules] However, since no packages are imported, xjavadoc has assumed that the referred classes
              [execmodules] belong to the same package as the referring class. The classes are:
              [execmodules] /web/jboss-3.2.1-src/common/src/main/org/jboss/net/protocol/URLListerBase.java --> URLFilter qualified to org.jboss.net.protocol.URLFilter
              [execmodules] /web/jboss-3.2.1-src/common/src/main/org/jboss/util/property/jmx/SystemPropertyClassValue.java --> SystemPropertyClassValueMBean qualified to org.jboss.util.property.jmx.SystemPropertyClassValueMBean

              compile-classes:
              [javac] Compiling 187 source files to /web/jboss-3.2.1-src/common/output/classes
              [execmodules] /web/jboss-3.2.1-src/common/src/main/org/jboss/util/property/jmx/SystemPropertyClassValue.java:28: interface expected here
              [execmodules] implements SystemPropertyClassValueMBean
              [execmodules] ^
              [execmodules] /web/jboss-3.2.1-src/common/src/main/org/jboss/logging/XPriority.java:79: warning: toPriority(java.lang.String) in org.apache.log4j.Priority has been deprecated
              [execmodules] public static Priority toPriority(String name)
              [execmodules] ^
              [execmodules] 1 error
              [execmodules] 1 warning

              BUILD FAILED
              file:/web/jboss-3.2.1-src/common/build.xml:259: Compile failed; see the compiler error output for details.
              //************************************

              thank u help! any other suggestion?

              • 4. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                Jon Barnett Master

                It looks like there is a problem with the SCO JDK working with JBoss. If this is the latest JDK from SCO, then you are probably stuck.

                You can thank Mr. McBride for his innovative, world beating IP.

                You could try an older JBoss version, say 3.0.x and see if the SCO JDK implements the necessary classes.

                • 5. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                  zxc Newbie

                  Oh my god! I try it with jdk1.3.1_04, the same error was appeared! Check the SCO JDK implements the necessary classes? Maybe it's a huge task, :), I want to try the sco jdk1.3.0,but I can't find download link from sco . I also use jboss3.0.6 to try ,it's useless.Sco site said that their jdk can run jboss on unixware ,I think it should also can run jboss,but now I am very sad! :(
                  What can I do ?

                  • 6. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                    Jon Barnett Master

                    In the next couple of days, I'm going to download a 1.3.x SDK for Linux and test this since this is now bugging me. I'll get back when I get this done but I've got other work in the meantime.

                    • 7. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                      zxc Newbie

                      Thank you jonlee! Maybe Jdk1.3.x for Linux runs well for jboss! But now I used Jdk1.3.1_08 (1.3.1_06), it 's not on Linux , Jdk for Unixware is different from this,which will cause the different result . :), I send a mail to sco, hope they will reply me!

                      Thanks again ,jonlee!
                      Do u have a msn account, hope to make friends with u ,mine is supine_312@hotmail.com

                      • 8. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                        Juha Lindfors Master

                        Does the XDoclet task correctly generate the org.jboss.util.property.jmx.SystemPropertyClassValueMBean class?

                        -- Juha

                        • 9. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                          Jon Barnett Master

                          No, I don't have an MSN account. I'm a Linux boy and unfortunately,try to steer clear of being tied to Microsoft. :)

                          I've compiled and run JBoss 3.2.0 with the IBM SDK, build 1.3.1, J2RE 1.3.1 IBM build cxia32131-20030618 on Linux. I'll now try with another 1.3.1 JDK, maybe Blackdown.

                          • 10. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                            Jon Barnett Master

                            I've also tried it with Blackdown, build Blackdown-1.3.1-02b-FCS and Sun, build 1.3.1_02-b02. Both these Linux JDKs work with JBoss 3.2.0. So I would say that the SCO Unixware implementation is missing something that other 1.3.1 implementations have or has implemented it incorrectly. Either that, or the JBoss 3.2.0 build using JDK 1.3.1 ensures run-time compatability with JDK 1.3.1 JVMs.

                            • 11. Re: can't run jboss3.2.1-tomcat4.1.24 on unixware7.1.1? help
                              Lamouret Newbie

                              Hi
                              Jboss3.2.1-tomcat4.1.24 can run on Unixware7.1.3 with one modification on jboss src.
                              I've replace line 880 of MainDeployer.java
                              "SubDeployer deployer = (SubDeployer) iterator.next();"
                              by "SubDeployerSupport deployer = (SubDeployerSupport) iterator.next();"

                              Hope it's help you.
                              Bruno