1 Reply Latest reply on Sep 25, 2003 5:59 AM by Vishal Sharma

    ERROR at start

    vacher Newbie

      Hello,
      i am trying to use Jboss with the plugin Lomboz of the IDE Eclipse.
      When Jboss is starting manually with run.bat, there is non problem. But with Lomboz (running arguments = "-c all"), the following errors appears :

      1) a warning :
      2003-09-24 16:47:25,757 WARN [org.jboss.system.ServiceController] Problem creating service jboss:service=HAJNDI
      java.lang.NoClassDefFoundError: gnu/regexp/UncheckedRE
      at javax.management.MatchQueryExp.(MatchQueryExp.java:117)
      at javax.management.Query.match(Query.java:268)
      at org.jboss.ha.jndi.HANamingService.findHAPartitionWithName(HANamingService.java:428)
      at org.jboss.ha.jndi.HANamingService.createService(HANamingService.java:279)
      at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:158)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      .....
      .....

      2) and an error :

      2003-09-24 16:47:51,644 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] MBeanException: Exception in MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:

      Incompletely deployed packages:

      MBeans waiting for classes:

      MBeans waiting for other MBeans:
      [ObjectName: jboss:service=HAJNDI
      state: FAILED
      I Depend On: jboss:service=DefaultPartition

      Depends On Me: java.lang.NoClassDefFoundError: gnu/regexp/UncheckedRE]


      And when I try after to use the server with a test client, I have got error with JNDI (name of EJB not bound).

      Why this error at start ?

      Thanks for any help,

      JF Vacher