2 Replies Latest reply on Oct 9, 2003 9:07 AM by stevecoh2

    Build 3.2.1 problem

    stevecoh2 Newbie

      I am moving myself from one Linux Box to the other. On the first
      JBoss built simply by running the build.sh script. The first was on SuSE 8.0, using jdk1.3.1_08. On the second box (RedHat 9.0) using jdk1.3.1_09, I get the errors in the attached file.

      Does anyone have a clue as to what is wrong here?

        • 1. Re: Build 3.2.1 problem
          stevecoh2 Newbie

          further info. I tried to use the jdk1.3.1-08 sdk that worked under suSe 8.0. No luck. Same Error. By the way, both of these were RPM distributions from Sun.

          I downloaded the non-RPM versionof jdk1.3.1_09 from Sun. Again, same problem. Is there some incompatibility between Sun's java and RedHat 9.0.

          Or is this a jboss problem? I haven't had any trouble building anything else with any of these javas.

          • 2. Re: Build 3.2.1 problem
            stevecoh2 Newbie

            Found the answer (thanks to a very knowledgeable fellow in my shop).

            The answer can be found here.

            http://hypermail.linklord.com/castor-dev/2003/Jun/1140.html

            Apparently RedHat by default assigns the environment variable LANG as follows:
            LANG="en_US.UTF-8"

            For some reason this blows things up.

            Changing it to
            LANG="en_US"

            makes the problem go away.

            Well, I'm glad I got it going but does anybody understand this?
            Or know why RedHat does this, or what I'm breaking by undoing it?