6 Replies Latest reply on Oct 26, 2004 1:38 PM by Kalyan

    JBoss-3.0.6 fails to start

    b_boyle18 Newbie

      Hi!
      I'm new to JBoss and I'm having trouble running it on my home PC. Funny thing is I have no problem running it in work but it just wont start when I run it on my home PC.
      MY home PC is Win2k but I have no network setup. I connect to the internet via a dialup connection. I have JDK1.4 and JBoss-3.0.6. MY enironment variables are all correct: JAVA_HOME=C:\java\jdk1.4 JBOSS_HOME=c:\java\jboss-3.0.6
      I was told that my problem might be my CLASSPATH so to get rid of it. I have done that and still no change.
      The error I'm getting is when jboss-service.xml is running and it is setting up something to do with security. It starts looking for C:\Java\jboss-3.0.6\config\security.properties but this of course doesnt exist.
      Any advice would be greatly appreciated because it is wrecking my head as to why I can get it working on my work PC and not on my home one. By the way my work PC is on a network. I was told that this might affect it. You can see my output with errors below.
      Cheers, B.

      C:\Java\jboss-3.0.6>run
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\Java\jboss-3.0.6\bin\\..
      .
      JAVA: C:\Java\JDK1.4\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat
      .
      CLASSPATH: ;C:\Java\JDK1.4\lib\tools.jar;C:\Java\jboss-3.0.6\bin\\run.jar
      .
      ===============================================================================
      .
      20:54:59,587 INFO [Server] JBoss Release: JBoss-3.0.6 CVSTag=JBoss_3_0_6
      20:54:59,677 INFO [Server] Home Dir: C:\Java\jboss-3.0.6
      20:54:59,677 INFO [Server] Home URL: file:/C:/Java/jboss-3.0.6/
      20:54:59,677 INFO [Server] Library URL: file:/C:/Java/jboss-3.0.6/lib/
      20:54:59,687 INFO [Server] Patch URL: null
      20:54:59,687 INFO [Server] Server Name: default
      20:54:59,687 INFO [Server] Server Home Dir: C:\Java\jboss-3.0.6\server\default
      20:54:59,687 INFO [Server] Server Home URL: file:/C:/Java/jboss-3.0.6/server/default/
      20:54:59,697 INFO [Server] Server Data Dir: C:\Java\jboss-3.0.6\server\default\db
      20:54:59,697 INFO [Server] Server Temp Dir: C:\Java\jboss-3.0.6\server\default\tmp
      20:54:59,717 INFO [Server] Server Config URL: file:/C:/Java/jboss-3.0.6/server/default/c
      onf/
      20:54:59,717 INFO [Server] Server Library URL: file:/C:/Java/jboss-3.0.6/server/default/
      lib/
      20:54:59,717 INFO [Server] Root Deployemnt Filename: jboss-service.xml
      20:54:59,727 INFO [Server] Starting General Purpose Architecture (GPA)...
      20:55:00,669 INFO [ServerInfo] Java version: 1.4.1_02,Sun Microsystems Inc.
      20:55:00,669 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.1_02-b06,Sun Micr
      osystems Inc.
      20:55:00,669 INFO [ServerInfo] OS-System: Windows 2000 5.0,x86
      20:55:00,819 INFO [ServiceController] Controller MBean online
      20:55:01,029 INFO [MainDeployer] Creating
      20:55:01,109 INFO [MainDeployer] Created
      20:55:01,109 INFO [MainDeployer] Starting
      20:55:01,109 INFO [MainDeployer] Started
      20:55:01,129 INFO [JARDeployer] Creating
      20:55:01,129 INFO [JARDeployer] Created
      20:55:01,129 INFO [JARDeployer] Starting
      20:55:01,129 INFO [MainDeployer] Adding deployer: org.jboss.deployment.JARDeployer@16df8
      4b
      20:55:01,139 INFO [JARDeployer] Started
      20:55:01,220 INFO [SARDeployer] Creating
      20:55:01,220 INFO [SARDeployer] Created
      20:55:01,220 INFO [SARDeployer] Starting
      20:55:01,220 INFO [MainDeployer] Adding deployer: org.jboss.deployment.SARDeployer@120cc
      56
      20:55:01,250 INFO [SARDeployer] Started
      20:55:01,250 INFO [Server] Core system initialized
      20:55:01,270 INFO [MainDeployer] Starting deployment of package: file:/C:/Java/jboss-3.0
      .6/server/default/conf/jboss-service.xml
      20:55:06,567 INFO [PropertyEditorManagerService] Creating
      20:55:06,567 INFO [PropertyEditorManagerService] Created
      20:55:06,567 INFO [SystemPropertiesService] Creating
      20:55:06,577 INFO [SystemPropertiesService] Created
      20:55:06,587 INFO [Log4jService] Creating
      20:55:06,587 INFO [Log4jService] Created
      20:55:06,597 INFO [WebService] Creating
      20:55:06,597 INFO [WebService] Created
      20:55:06,597 INFO [NamingService] Creating
      20:55:06,597 INFO [NamingService] Created
      20:55:06,597 INFO [JNDIView] Creating
      20:55:06,597 INFO [JNDIView] Created
      20:55:06,597 INFO [SecurityConfig] Creating
      20:55:06,627 INFO [SecurityConfig] Created
      20:55:06,627 INFO [XMLLoginConfig] Creating
      20:55:06,627 INFO [XMLLoginConfig] Created
      20:55:06,627 INFO [JaasSecurityManagerService] Creating
      20:55:06,627 INFO [JaasSecurityManagerService] Created
      20:55:06,657 INFO [TransactionManagerService] Creating
      20:55:06,657 INFO [TransactionManagerService] Created
      20:55:06,657 INFO [ClientUserTransactionService] Creating
      20:55:06,657 INFO [ClientUserTransactionService] Created
      20:55:06,677 INFO [CachedConnectionManager] Creating
      20:55:06,677 INFO [CachedConnectionManager] Created
      20:55:06,677 INFO [EARDeployer] Creating
      20:55:06,697 INFO [EARDeployer] Created
      20:55:06,697 INFO [JRMPInvoker] created
      20:55:06,697 INFO [PooledInvoker] Creating
      20:55:06,717 INFO [PooledInvoker] Created
      20:55:06,717 INFO [LocalInvoker] Creating
      20:55:06,727 INFO [LocalInvoker] Created
      20:55:06,738 INFO [URLDeploymentScanner] Creating
      20:55:06,738 INFO [URLDeploymentScanner] Created
      20:55:06,738 INFO [PropertyEditorManagerService] Starting
      20:55:06,738 INFO [PropertyEditorManagerService] Started
      20:55:06,768 INFO [AbstractDeploymentScanner$ScannerThread] Running
      20:55:06,768 INFO [SystemPropertiesService] Starting
      20:55:06,768 INFO [SystemPropertiesService] Started
      20:55:06,768 INFO [Log4jService] Starting
      20:55:06,788 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.
      xml
      20:55:07,348 INFO [Log4jService] Started
      20:55:08,109 INFO [WebService] Starting
      20:55:08,190 INFO [WebService] Started webserver with address: null port: 8083
      20:55:08,190 INFO [WebService] Codebase set to: http://brianwin2k:8083/
      20:55:08,190 INFO [WebService] Started
      20:55:08,190 INFO [NamingService] Starting
      20:55:08,230 INFO [NamingService] Starting jnp server
      20:55:08,851 INFO [NamingService] Started jnpPort=1099, rmiPort=0, backlog=50, bindAddre
      ss=null, Client SocketFactory=null, Server SocketFactory=org.jboss.net.sockets.DefaultSoc
      ketFactory@ad093076
      20:55:09,602 ERROR [STDERR] java.io.FileNotFoundException: C:\Java\jboss-3.0.6\config\sec
      urity.properties (The system cannot find the path specified)
      20:55:09,602 ERROR [STDERR] at java.io.FileInputStream.open(Native Method)
      20:55:09,602 ERROR [STDERR] at java.io.FileInputStream.(FileInputStream.java:10
      3)
      20:55:09,602 ERROR [STDERR] at com.sun.enterprise.util.Utility.getPropertiesFromFile(
      Utility.java:42)
      20:55:09,612 ERROR [STDERR] at com.sun.enterprise.iiop.POAEJBORB.(POAEJBORB.j
      ava:78)
      20:55:09,612 ERROR [STDERR] at java.lang.Class.forName0(Native Method)
      20:55:09,632 ERROR [STDERR] at java.lang.Class.forName(Class.java:217)
      20:55:09,632 ERROR [STDERR] at org.omg.CORBA.ORB.create_impl(ORB.java:295)
      20:55:09,632 ERROR [STDERR] at org.omg.CORBA.ORB.init(ORB.java:336)
      20:55:09,652 ERROR [STDERR] at com.sun.enterprise.util.ORBManager.createORB(ORBManage
      r.java:138)
      20:55:09,652 ERROR [STDERR] at com.sun.enterprise.util.ORBManager.init(ORBManager.jav
      a:65)
      20:55:09,672 ERROR [STDERR] at com.sun.enterprise.naming.SerialInitContextFactory.<in
      it>(SerialInitContextFactory.java:31)
      20:55:09,692 ERROR [STDERR] at sun.reflect.NativeConstructorAccessorImpl.newInstance0
      (Native Method)
      20:55:09,692 ERROR [STDERR] at sun.reflect.NativeConstructorAccessorImpl.newInstance(
      NativeConstructorAccessorImpl.java:39)
      20:55:09,712 ERROR [STDERR] at sun.reflect.DelegatingConstructorAccessorImpl.newInsta
      nce(DelegatingConstructorAccessorImpl.java:27)
      20:55:09,732 ERROR [STDERR] at java.lang.reflect.Constructor.newInstance(Constructor.
      java:274)
      20:55:09,732 ERROR [STDERR] at java.lang.Class.newInstance0(Class.java:306)
      20:55:09,752 ERROR [STDERR] at java.lang.Class.newInstance(Class.java:259)
      20:55:09,752 ERROR [STDERR] at javax.naming.spi.NamingManager.getInitialContext(Namin
      gManager.java:649)
      20:55:09,752 ERROR [STDERR] at javax.naming.InitialContext.getDefaultInitCtx(InitialC
      ontext.java:243)
      20:55:09,782 ERROR [STDERR] at javax.naming.InitialContext.init(InitialContext.java:2
      19)
      20:55:09,782 ERROR [STDERR] at javax.naming.InitialContext.(InitialContext.java
      :175)
      20:55:09,812 ERROR [STDERR] at org.jboss.naming.NamingService.startService(NamingServ
      ice.java:173)
      20:55:09,812 ERROR [STDERR] at org.jboss.system.ServiceMBeanSupport.start(ServiceMBea
      nSupport.java:165)
      20:55:09,822 ERROR [STDERR] at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown So
      urce)
      20:55:09,842 ERROR [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Delega
      tingMethodAccessorImpl.java:25)
      21:03:38,113 ERROR [STDERR] at java.lang.reflect.Method.invoke(Method.java:324)
      21:03:38,113 ERROR [STDERR] at org.jboss.mx.capability.ReflectedMBeanDispatcher.invok
      e(ReflectedMBeanDispatcher.java:284)
      21:03:38,113 ERROR [STDERR] at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServer
      Impl.java:517)