4 Replies Latest reply on Dec 8, 2003 8:37 AM by vinodmanickam

    problems starting jboss 3.2.2

    Sven Baumgarten Newbie

      Hi everyone!

      I've downloaded the jboss-3.2.2.zip. After extraction I started jboss by run.bat - jboss started. Then I shut jboss down by "shutdown.bat -S". Now I try to start jboss again and I get the following error:
      (its is only a snip of the log file)

      13:12:35,633 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      13:12:36,195 INFO [LocalJBossServerDomain] Started jboss.management.local:j2eeType=J2EEDomain,name=M
      13:12:36,195 INFO [Log4jService] Started jboss.system:type=Log4jService,service=Logging
      13:12:36,195 INFO [AbstractDeploymentScanner$ScannerThread] Running
      13:12:36,226 INFO [WebService] Started WebServer with address: 0.0.0.0:8083
      13:12:36,226 INFO [WebService] Using RMI server codebase: http://0.0.0.0:8083/
      13:12:36,226 INFO [WebService] Started jboss:service=WebService
      13:12:36,242 INFO [NamingService] Starting jnp server
      13:12:36,351 ERROR [NamingService] Starting failed
      java.rmi.server.ExportException: Port already in use: 1098; nested exception is:
      java.net.BindException: Address already in use: JVM_Bind
      at sun.rmi.transport.tcp.TCPTransport.listen(TCPTransport.java:243)
      at sun.rmi.transport.tcp.TCPTransport.exportObject(TCPTransport.java:178)
      at sun.rmi.transport.tcp.TCPEndpoint.exportObject(TCPEndpoint.java:382)
      at sun.rmi.transport.LiveRef.exportObject(LiveRef.java:116)
      at sun.rmi.server.UnicastServerRef.exportObject(UnicastServerRef.java:145)
      at sun.rmi.server.UnicastServerRef.exportObject(UnicastServerRef.java:129)
      at java.rmi.server.UnicastRemoteObject.exportObject(UnicastRemoteObject.java:275)
      at java.rmi.server.UnicastRemoteObject.exportObject(UnicastRemoteObject.java:206)
      at org.jnp.server.Main.initJnpInvoker(Main.java:376)
      at org.jnp.server.Main.start(Main.java:249)
      at org.jboss.naming.NamingService.startService(NamingService.java:164)
      at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:192)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
      at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:976)
      at $Proxy0.start(Unknown Source)
      at org.jboss.system.ServiceController.start(ServiceController.java:394)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)


      The problem still remains after restart the computer.

      Last time I developed on jboss 3.2.2.RC02 and where were no problems. Does anybody know a solution for that problem?

      Thanks,
      Sven