0 Replies Latest reply on Dec 22, 2003 5:02 AM by rach_msgbd

    sporadic startup problems

    rach_msgbd Newbie

      Hi, our software uses limited jboss functionality at present, I believe just messaging aspect. However we're seeing varying stability accross different machines on the startup of the application. I've had startup problems at a customer site recently on unix and windows, below are the errors I see on startup. Please ask me if you need any further info, I've tried to restrict the verbose stuff

      20:17:30,481 FATAL [AppRootServer] Could not register server facade object: is the rmiregistry running? java.rmi.ConnectIOException: non-JRMP server at remote endpoint

      20:17:30,512 WARN [UILServerILService] SocketException occured (Connection reset by peer?). Cannot initialize the UILServerILService.

      javax.jms.JMSException: The destination is being used.
      at org.jboss.mq.server.JMSDestinationManager.closeDestination(JMSDestinationManager.java:809)
      ...

      20:17:30,543 WARN [Connection] Connection failure:
      org.jboss.mq.SpyJMSException: Connection Failed; - nested throwable: (java.net.SocketException: Software caused connection abort: socket write error)

      20:17:30,543 ERROR [JMSMessageTopicConcreteFactory] Could not obtain TopicConnection, TopicSession, TopicSender: Cannot get a client ID: null; - nested throwable: (java.io.EOFException)


      jnp server is running on port 1099 and rmi registry on port 1100. I tried installing the jdk 1.4.1_05 and 1.4.1_06 but had the same results on both the version of jboss is 3.0.6. As I said this works fine in our office but not on another site. I checked that none of the ports were blocked on the machine.

      Many thanks for any assistance