3 Replies Latest reply on Jan 4, 2004 12:17 AM by Yan Huai Han

    automatic startup on redhat

    zsoltvincze Newbie

      I've just installed jboss on redhat 8 and trying to use the jboss_init_redhat.sh that comes with the installaton. I've modified the JBOSS_HOME and the JAVAPTH variables in the script. When I run it, it seem to run but jboss is inaccesible. If I run the run.sh it works ok.

      Could sy send me a script that actually works or make a suggestion what I should do to make this one work.

        • 1. Re: automatic startup on redhat
          Erik Reuter Newbie

          Have you added the "jboss" user and chown'ed the jboss dir structure to that user?

          I added the following env vars to get JBoss behave nicely with the start script as well:

          JBOSS_HOME (points to wherever you stuck jboss)
          JBOSS_CONSOLE (where the console log will be written)
          JAVA_OPTS (additional options for the jvm)

          • 2. Re: automatic startup on redhat
            Yan Huai Han Newbie

             

            "zsoltvincze" wrote:
            I've just installed jboss on redhat 8 and trying to use the jboss_init_redhat.sh that comes with the installaton. I've modified the JBOSS_HOME and the JAVAPTH variables in the script. When I run it, it seem to run but jboss is inaccesible. If I run the run.sh it works ok.

            Could sy send me a script that actually works or make a suggestion what I should do to make this one work.



            me too.
            it shows:
            WARNING: location for saving console log invalid: /opt/jboss3/log
            WARNING: ignoring it and using /dev/null
            CMD_START = cd /opt/jboss3/bin; /opt/jboss3/bin/run.sh -c all

            jboss didn't startup.

            • 3. Re: automatic startup on redhat
              Yan Huai Han Newbie

               

              "lovelotus" wrote:
              "zsoltvincze" wrote:
              I've just installed jboss on redhat 8 and trying to use the jboss_init_redhat.sh that comes with the installaton. I've modified the JBOSS_HOME and the JAVAPTH variables in the script. When I run it, it seem to run but jboss is inaccesible. If I run the run.sh it works ok.

              Could sy send me a script that actually works or make a suggestion what I should do to make this one work.



              me too.
              it shows:
              WARNING: location for saving console log invalid: /opt/jboss3/log
              WARNING: ignoring it and using /dev/null
              CMD_START = cd /opt/jboss3/bin; /opt/jboss3/bin/run.sh -c all

              jboss didn't startup.


              soryy, just a moment, it has run!