6 Replies Latest reply on Jan 15, 2004 6:23 AM by miss_jinx81

    jboss 3.0.4 abnormal termination

    miss_jinx81 Newbie

      hi guys,


      i have this problem with jboss. the jboss process terminates itself without any exception(yup, it's definitely suicide)..
      weird thing is, no exception can be found in the logs...

      this problem does not occur often, so we are having a hard time reproducing it. i dont know what the real cause is but based on the logs, jboss terminates when :
      a. the application is trying to access data from the database or
      b. the application sends an object message via JMS

      i would like to note that before, we send one object at a time.. at present, we are implementing 'batch sending' where one object can contain other objects... could this be a factor?


      btw, i am currently using j2sdk1.4.1_02 and postgresql-7.3

      i know it's kinda vague...but i do hope one of you guys can help me out

      thanks for your time :D

        • 1. Re: jboss 3.0.4 abnormal termination
          Darran Lofthouse Master

          Are you running on a Unix operating system?

          If you are have you searched the forum, I know people have experienced this problem when stray signals are sent to the JVM processes.

          • 2. Re: jboss 3.0.4 abnormal termination
            miss_jinx81 Newbie

            hi,

            or application is running on solaris environment


            i forgot to mention that we are using cron for scheduled tasks , like deleting records from db... i dont know if this is significant info...


            i searched the forum for similar problems, somehow i wasnt able to find a relevant thread.. must be using the wrong keys...


            thanx a lot :D

            • 3. Re: jboss 3.0.4 abnormal termination
              DRAI William Newbie

              Do you run your server with
              nohup ./run.sh &

              I remember we had some problems like this on Solaris when not using nohup.

              • 4. Re: jboss 3.0.4 abnormal termination
                miss_jinx81 Newbie

                hi wdrai,


                nope we dont use nohup...

                the script that launches jboss simply uses this:
                %JBOSS_HOME%\bin\run.bat


                can you please descibe to me the nature of the problem you encountered?
                it would help me a lot in narrowing down the list of possible causes ...

                what i know so far is that versions prior to the implementation of 'batch sending ' via JMS and cron-jobs, the application server worked fine...

                now the jboss process is terminated (but not always, though)... and i still can't point the main culprit :D

                thanx :D

                • 5. Re: jboss 3.0.4 abnormal termination
                  DRAI William Newbie

                  If you are on solaris, I suppose your script uses run.sh.

                  Our problem was that sometimes we restarted the server manually from a terminal. When the terminal was disconnected (manually or not), jboss was sometimes shut down because it received a SIGTERM. It happened at unpredictable times because we often left our terminal window open.
                  Then our Unix system administrators saved us by telling us to use nohup to prevent jboss from getting the SIGTERM.

                  I don't know if it is the same problem you have but it was almost impossible for us to find a good reason for the jboss shutdown. We had searched all possible causes in our application code with no success, and it really was a system thing.

                  • 6. Re: jboss 3.0.4 abnormal termination
                    miss_jinx81 Newbie

                    hi guys,
                    *yup, it's run.sh.. sorry 'bout that :D*

                    i just want to add a few things...

                    i found a core file in the $JBOSS_HOME/bin directory... i also found something interesting... a hs_err_pid*.log file...

                    The bottom of the file contains the following lines:
                    # HotSpot Virtual Machine Error : 11
                    # Error ID : 4F530E43505002E6
                    # Please report this error at
                    # http://java.sun.com/cgi-bin/bugreport.cgi

                    as i dug deeper, i found out that signal 11 denotes segmentation fault. It means that “the program accessed a memory location that was not assigned”(see http://www.bitwizard.nl/sig11/).

                    this turns out to be a jvm bug and there's no solution for that yet..

                    fyi, i used this workaround , i added
                    -Xint –Xrs to the vm options... and it worked, it solved part of the problem

                    i was about to say that it's definitely a vm problem until i saw a statement in another forum that says:
                    "I have seen this problem come up with a variety of applications, most notably JBoss 3.X."

                    what i wanted to find out is that is there something i can do to prevent this from happening again?

                    i mean is there anything in the jboss config that i can modify? or are there operations(i.e. accessing the database, sending large data via the jms) that can take up lots of memory?

                    thanks a lot guys