0 Replies Latest reply on Jan 19, 2004 7:22 AM by surajmundada

    idleremover notifying connection pool + unable to passivate

    surajmundada Newbie

      Hi

      I am using JBoss 3.2.0 Tomcat 4.1.24 with Postgres as backend.

      I have deployed a EAR which has 16 different beans. Function of one of the beans is to get 60-70 fields from 13-14 different database tables, form a XML from all the fields and return that XML as response.

      I have created a view table in the database so that I can get all the required fields in a single query.

      I have packaged all the code in stateful session bean to avoid information mixing.

      For 3 days, it worked fine but now it's giving the following in the log.

      O [STDOUT] capFileName = 20040118100004.jpg
      2004-01-18 22:00:04,078 INFO [STDOUT] read = 929
      2004-01-18 22:02:34,220 DEBUG org.jboss.resource.connectionmanager.IdleRemover] run: IdleRemover notifying pools, interval: 450000

      2004-01-18 22:06:10,330 DEBUG [org.jboss.ejb.plugins.StatefulSessionFilePersistenceManager] Removing passivated state file: /opt/jboss-3.2.1_tomcat-4.1.24/server/default/tmp/sessions/GetProfileBean-dph12i7b-3/dpm3nbsu-wm.ser

      2004-01-18 22:06:10,343 DEBUG [org.jboss.ejb.plugins.StatefulSessionFilePersistenceManager] Removing passivated state file: /opt/jboss-3.2.1_tomcat-4.1.24/server/default/tmp/sessions/GetProfileBean-dph12i7b-3/dpm3n0dm-wl.ser


      It is also giving following
      2004-01-18 21:13:30,574 INFO [STDOUT] user id == crhamill_100

      2004-01-18 21:13:30,588 WARN [org.jboss.ejb.plugins.AbstractInstanceCache] Unable to passivate due to ctx lock, id=danielbastian_101
      2004-01-18 21:13:30,589 WARN [org.jboss.ejb.plugins.AbstractInstanceCache] Unable to passivate due to ctx lock, id=suzid_100

      2004-01-18 21:13:30,598 INFO [STDOUT] In doGet of servlet..#######################


      My jboss.xml contains following as a part of configuration in </container-configurations> tag :

      <container-pool-conf>
      10
      100
      </container-pool-conf>
      <commit-option>A</commit-option>

      any ideas how to solve this and improve the performance ?

      Thanks,

      Suraj