5 Replies Latest reply on Feb 6, 2004 9:50 AM by Juha Lindfors

    JBoss 3.2.3 restarts involuntarily on Windows NT

    Erik Sliman Apprentice

      Can someone please help shed some light on why I may be having deployment problems?

      PROBLEM: JBoss restarts every time you try to access an application on Windows NT.

      NT and 2000 setup:
      JAVA_HOME: $JAVA_INSTALL\j2sdk1.4.0_03
      J2EE_HOME: $JAVA_INSTALL\j2sdkee1.3.1

      In the process of upgrading an NT box from 3.0.6 to 3.2.3 I got JBoss 3.2.3 completely working on Windows 2000. The out of the box install works on Windows 2000. You can immediately access jmx-console or web-console applications via localhost:8080. I reconfigured it to work with the EAR applications I deployed to it, and it works great on Windows 2000.

      To upgrade the NT box, I copied the reconfigured and solidly working copy of JBoss 3.2.3 from Windows 2000 to NT. Every time I tried to access it the application on port 8080, it restarted JBoss, and the web browser reports that it couldn't get a connection. The first line of output on the console is:

      [Server] Starting JBoss (MX MicroKernel)...

      When I removed the root application, attempts to access it correctly return the HTTP Status 500 from Apache Tomcat/4.1.29, and the JBoss console correctly shows a MAPPING configuration error. However, correct URLs pointing to remaining applications still restarted JBoss.

      I decided to try a clean install without any applications, since this worked on Windows 2000. Sure enough, attempts to access jmx-console or web-console, two applications that work out of the box, resulted in the same problem.

      The only difference I can discern between the two machines, since they are using the same versions of JBoss and Java, is one is Windows NT and one is Windows 2000.

      If I rerun JBoss 3.0.6, it runs without problems. This issue is specific to JBoss 3.2.3.

      Some people may be asking why I choose to continue to use Windows NT. The reason is simple. It runs several server programs, and runs them well. If it isn't broken, don't fix it. However, this is the first time it appears to be "broken", although the problem is spefic to an upgrade of JBoss 3.2.3. Does it work on NT on other people's machines?