4 Replies Latest reply on Feb 6, 2004 10:55 AM by Juha Lindfors

    All threads are busy

    surajmundada Newbie

      Hi

      I am using JBOSS 3.2.0 Tomcat 4.1.124 on solaris machine.

      I have deployed a EAR file on JBOSS which contains mix of session beans and entity beans.

      Recently, I got following error on it.

      ---------------------------------------------------------------------------

      2004-02-01 21:37:31,757 INFO [STDOUT] user id == stucki_104
      2004-02-01 21:37:31,762 ERROR [org.apache.tomcat.util.threads.ThreadPool] All threads are busy, waiting. Please increase maxThreads or check the servlet status10 10
      2004-02-01 21:37:31,775 INFO [STDOUT] In doGet of servlet..#######################
      2004-02-01 21:37:31,776 INFO [STDOUT] user id == mcintyre_100

      ----------------------------------------------------------------------------------
      Can anybody tell which configuration file and which field in that file should be modified so that I can get around this problem ?

      Thanks,

      Suraj

        • 1. Re: All threads are busy
          Bill Burke Master

          You using the 'default' jboss configuration?

          If so, config file for tomcat is in

          jboss/default/deploy/jbossweb-tomcat.sar/META-INF/jboss-service.xml

          You should see maxProcessors attribute somewhere in there.

          Bill

          • 2. Re: All threads are busy
            surajmundada Newbie

            thanks Bill !

            my jboss-service.xml contains following :

            ---------------------------------------------------------------------------------
            <!-- A HTTP/1.1 Connector on port 8080 -->
            <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
            port="8080" minProcessors="3" maxProcessors="10"
            enableLookups="true" acceptCount="10" debug="0"
            connectionTimeout="20000" useURIValidationHack="false" />

            -----------------------------------------------------------------------------------

            What is the maximum value I can put for maxProcessors ?

            Is it the only parameter which I need to modify ?

            Suraj

            • 3. Re: All threads are busy
              surajmundada Newbie

              yes I am using the default configuration

              • 4. Re: All threads are busy
                Juha Lindfors Master

                Max depends how many concurrent threads your machine can handle and how many concurrent requests you expect to hit your web application. It's highly specific to your application, you can make some educated guesses but ultimately you need to load test on your production machine to find the ideal settings.