6 Replies Latest reply on Feb 8, 2004 7:35 AM by Alexander F.

    jboss does not start

    Alexander F. Newbie

      Hello,

      I have downloaded the full jboss 3.2 bzip2 archive for linux.
      After unpacking I want to run the ./run.sh in jboss-3.2.3/bin.
      But while starting jboss I get several errors like

      14:41:36,584 ERROR [EmbeddedTomcatService] Starting failed
      org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@e4245 for org.apache.commons.logging.impl.Log4JLogger
      at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:532)
      ...


      14:41:36,616 WARN [ServiceController] Problem starting service jboss.web:service=WebServer
      org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@e4245 for org.apache.commons.logging.impl.Log4JLogger
      at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:532)
      ...


      14:41:50,140 WARN [JBossManagedConnectionPool] Throwable while attempting to get a new connection:
      org.jboss.resource.JBossResourceException: Could not create connection; - nested throwable: (java.sql.SQLException: File input/output error: /usr/local/jboss-3.2.3/server/default/data/hypersonic/localDB.script)
      at org.jboss.resource.adapter.jdbc.local.LocalManagedConnectionFactory.createManagedConnection(LocalManagedConnectionFactory.java:160)
      ...


      So finally I get the following message:



      MBeans waiting for other MBeans:
      [ObjectName: jboss.mq:service=InvocationLayer,type=HTTP
      state: CONFIGURED
      I Depend On: jboss.mq:service=Invoker
      jboss.web:service=WebServer

      Depends On Me: , ObjectName: jboss.web:service=WebServer
      state: FAILED
      I Depend On: jboss:service=TransactionManager

      Depends On Me: jboss.mq:service=InvocationLayer,type=HTTP
      org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@e4245 for org.apache.commons.logging.impl.Log4JLogger]



      So what's the problem and what can I do?

      Thanks in advance,
      Alex

        • 1. Re: jboss does not start
          Solomon Movva Newbie

          First verify if you were able to untar all the classes. Especially the ones at the end of a long dir structure. The regular tar may have an issue with long dir structure. You may have to use gnutar if that's the case,

          Verify the classes under the dir 'jboss-3.2.3/server/default/deploy'.

          Hope this helps!

          • 2. Re: jboss does not start
            Alexander F. Newbie

            I have used the GNU tar and extracted all files without any error.
            The path jboss-3.2.3/server/default/deploy contains following files:


            cache-invalidation-service.xml
            client-deployer-service.xml
            hsqldb-ds.xml
            http-invoker.sar
            jboss-jca.sar
            jboss-local-jdbc.rar
            jboss-xa-jdbc.rar
            jbossweb-tomcat41.sar
            jms
            jmx-console.war
            jmx-invoker-adaptor-server.sar
            mail-service.xml
            management
            properties-service.xml
            schedule-manager-service.xml
            scheduler-service.xml
            snmp-adaptor.sar
            sqlexception-service.xml
            transaction-service.xml
            user-service.xml
            uuid-key-generator.sar

            So why does jboss always throw an exception when starting?
            No suitable Log constructor [Ljava.lang.Class;@e4245 for org.apache.commons.logging.impl.Log4JLogger

            What can I do?


            • 3. Re: jboss does not start
              Juha Lindfors Master

              Do you have apache commons somewhere in your system classpath, in JDK/lib/ext for example?

              • 4. Re: jboss does not start
                Alexander F. Newbie

                apache commons? jdk/lib/ext?
                what exactly do you mean? which directory has to be in my classpath? perhaps this is missing...?

                here is my classpath:
                echo $CLASSPATH
                /usr/local/j2sdk1.4.2_nb/j2sdk1.4.2/:/usr/local/j2sdk1.4.2_nb/j2sdk1.4.2/lib:/usr/local/j2sdk1.4.2_nb/j2sdk1.4.2/lib/tools.jar:/usr/local/jboss-3.2.3/bin/run.jar:/usr/local/jwsdp-1.3/saaj/lib/lib/tools.jar:/usr/local/jwsdp-1.3/saaj/lib:.

                So my java-path is /usr/local/j2sdk1.4.2_nb/j2sdk1.4.2.
                What is the apache common-path? and where is the jdk/lib/ext path?

                Thanks in advance,
                Alex

                • 5. Re: jboss does not start
                  Juha Lindfors Master

                  Have a look at your j2sdk1.4.2_nb/jre/lib/ext and make sure there isn't anything extra there. Unsetting your system classpath might also be a good idea (although the start scripts should do this already) before you start JBoss.

                  • 6. Re: jboss does not start
                    Alexander F. Newbie

                    Thats it!
                    I have had some .jar-files belonging to the jwsdp in the jdk/lib/ext folder. Without it the server run whithout any problems!
                    Thanks a lot!

                    Alex