5 Replies Latest reply on Apr 10, 2009 3:41 AM by Ilya Shaikovsky

    Building Richfaces 3.3.0

    Jubril Adisa Novice

      I downloaded richfaces3.3.0 Source yesterday and i am having a hard time building it, I am getting this exception whenever i run mvn -install , is there a way i can get the complete source



      C:\richfaces-ui-3.3.0.GA\framework>mvn -e install
      + Error stacktraces are turned on.
      [INFO] Scanning for projects...
      [INFO] Reactor build order:
      [INFO] Java Server Faces AJAX framework
      [INFO] Java Server Faces AJAX framework API
      [INFO] Java Server Faces AJAX framework implementation
      [INFO] Ajax4Jsf test framework
      [INFO] jsf-test
      Downloading: http://download.java.net/maven/1/org.apache.maven.wagon/poms/wagon-
      webdav-1.0-beta-2.pom
      Downloading: http://repository.jboss.org/maven2/org/apache/maven/wagon/wagon-web
      dav/1.0-beta-2/wagon-webdav-1.0-beta-2.pom
      Downloading: http://repo1.maven.org/maven2/org/apache/maven/wagon/wagon-webdav/1
      .0-beta-2/wagon-webdav-1.0-beta-2.pom
      Downloading: http://download.java.net/maven/1/org.codehaus.plexus/poms/plexus-ut
      ils-1.1.pom
      Downloading: http://repository.jboss.org/maven2/org/codehaus/plexus/plexus-utils
      /1.1/plexus-utils-1.1.pom
      Downloading: http://repo1.maven.org/maven2/org/codehaus/plexus/plexus-utils/1.1/
      plexus-utils-1.1.pom
      Downloading: http://download.java.net/maven/1/org.apache.maven.wagon/jars/wagon-
      webdav-1.0-beta-2.jar
      Downloading: http://repository.jboss.org/maven2/org/apache/maven/wagon/wagon-web
      dav/1.0-beta-2/wagon-webdav-1.0-beta-2.jar
      Downloading: http://repo1.maven.org/maven2/org/apache/maven/wagon/wagon-webdav/1
      .0-beta-2/wagon-webdav-1.0-beta-2.jar
      Downloading: http://download.java.net/maven/1/org.codehaus.plexus/jars/plexus-ut
      ils-1.1.jar
      Downloading: http://repository.jboss.org/maven2/org/codehaus/plexus/plexus-utils
      /1.1/plexus-utils-1.1.jar
      Downloading: http://repo1.maven.org/maven2/org/codehaus/plexus/plexus-utils/1.1/
      plexus-utils-1.1.jar
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Failed to resolve artifact.
      
      Missing:
      ----------
      1) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.maven.wagon -DartifactId=wag
      on-webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file
      
       Alternatively, if you host your own repository you can deploy the file there:
      
       mvn deploy:deploy-file -DgroupId=org.apache.maven.wagon -DartifactId=wagon
      -webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -D
      repositoryId=[id]
      
       Path to dependency:
       1) org.richfaces:framework:pom:3.3.0.GA
       2) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
      
      2) org.codehaus.plexus:plexus-utils:jar:1.1
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=org.codehaus.plexus -DartifactId=plexus
      -utils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file
      
       Alternatively, if you host your own repository you can deploy the file there:
      
       mvn deploy:deploy-file -DgroupId=org.codehaus.plexus -DartifactId=plexus-u
      tils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -Drepository
      Id=[id]
      
       Path to dependency:
       1) org.richfaces:framework:pom:3.3.0.GA
       2) org.codehaus.plexus:plexus-utils:jar:1.1
      
      ----------
      2 required artifacts are missing.
      
      for artifact:
       org.richfaces:framework:pom:3.3.0.GA
      
      from the specified remote repositories:
       central (http://repo1.maven.org/maven2),
       repository.jboss.org (http://repository.jboss.org/maven2),
       maven-repository.dev.java.net (http://download.java.net/maven/1)
      
      
      
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Missing:
      ----------
      1) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.maven.wagon -DartifactId=wag
      on-webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file
      
       Alternatively, if you host your own repository you can deploy the file there:
      
       mvn deploy:deploy-file -DgroupId=org.apache.maven.wagon -DartifactId=wagon
      -webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -D
      repositoryId=[id]
      
       Path to dependency:
       1) org.richfaces:framework:pom:3.3.0.GA
       2) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
      
      2) org.codehaus.plexus:plexus-utils:jar:1.1
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=org.codehaus.plexus -DartifactId=plexus
      -utils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file
      
       Alternatively, if you host your own repository you can deploy the file there:
      
       mvn deploy:deploy-file -DgroupId=org.codehaus.plexus -DartifactId=plexus-u
      tils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -Drepository
      Id=[id]
      
       Path to dependency:
       1) org.richfaces:framework:pom:3.3.0.GA
       2) org.codehaus.plexus:plexus-utils:jar:1.1
      
      ----------
      2 required artifacts are missing.
      
      for artifact:
       org.richfaces:framework:pom:3.3.0.GA
      
      from the specified remote repositories:
       central (http://repo1.maven.org/maven2),
       repository.jboss.org (http://repository.jboss.org/maven2),
       maven-repository.dev.java.net (http://download.java.net/maven/1)
      
      
       at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(De
      faultLifecycleExecutor.java:166)
       at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
      fecycleExecutor.java:140)
       at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
       at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
       at org.apache.maven.cli.MavenCli.main(MavenCli.java:301)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
       at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
       at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      
       at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.artifact.resolver.MultipleArtifactsNotFoundException
      : Missing:
      ----------
      1) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.maven.wagon -DartifactId=wag
      on-webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file
      
       Alternatively, if you host your own repository you can deploy the file there:
      
       mvn deploy:deploy-file -DgroupId=org.apache.maven.wagon -DartifactId=wagon
      -webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -D
      repositoryId=[id]
      
       Path to dependency:
       1) org.richfaces:framework:pom:3.3.0.GA
       2) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
      
      2) org.codehaus.plexus:plexus-utils:jar:1.1
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=org.codehaus.plexus -DartifactId=plexus
      -utils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file
      
       Alternatively, if you host your own repository you can deploy the file there:
      
       mvn deploy:deploy-file -DgroupId=org.codehaus.plexus -DartifactId=plexus-u
      tils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -Drepository
      Id=[id]
      
       Path to dependency:
       1) org.richfaces:framework:pom:3.3.0.GA
       2) org.codehaus.plexus:plexus-utils:jar:1.1
      
      ----------
      2 required artifacts are missing.
      
      for artifact:
       org.richfaces:framework:pom:3.3.0.GA
      
      from the specified remote repositories:
       central (http://repo1.maven.org/maven2),
       repository.jboss.org (http://repository.jboss.org/maven2),
       maven-repository.dev.java.net (http://download.java.net/maven/1)
      
      
       at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
      nsitively(DefaultArtifactResolver.java:324)
       at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
      nsitively(DefaultArtifactResolver.java:288)
       at org.apache.maven.extension.DefaultExtensionManager.addExtension(Defau
      ltExtensionManager.java:132)
       at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(De
      faultLifecycleExecutor.java:158)
       ... 12 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 4 minutes 20 seconds
      [INFO] Finished at: Thu Apr 09 11:30:21 EDT 2009
      [INFO] Final Memory: 1M/3M
      [INFO] ------------------------------------------------------------------------
      C:\richfaces-ui-3.3.0.GA\framework>


        • 1. Re: Building Richfaces 3.3.0
          Nick Belaevski Master

          Hello,

          Probably, some issue with local repository. Have you tried cleaning it?

          • 2. Re: Building Richfaces 3.3.0
            Jubril Adisa Novice

            Please how do i clean the repository

            • 3. Re: Building Richfaces 3.3.0
              Nick Belaevski Master

              Delete %USERPROFILE%\.m2 folder.

              • 4. Re: Building Richfaces 3.3.0
                Jubril Adisa Novice

                Same result after deleted local repository

                C:\Documents and Settings\Local User>del .m2
                C:\Documents and Settings\Local User\.m2\*, Are you sure (Y/N)? Y
                
                C:\Documents and Settings\Local User>cd\
                
                C:\>cd richfaces-ui-3.3.0.GA
                
                C:\richfaces-ui-3.3.0.GA>cd framework
                
                C:\richfaces-ui-3.3.0.GA\framework>mvn -e install
                + Error stacktraces are turned on.
                [INFO] Scanning for projects...
                [INFO] Reactor build order:
                [INFO] Java Server Faces AJAX framework
                [INFO] Java Server Faces AJAX framework API
                [INFO] Java Server Faces AJAX framework implementation
                [INFO] Ajax4Jsf test framework
                [INFO] jsf-test
                Downloading: http://download.java.net/maven/1/org.apache.maven.wagon/poms/wagon-
                webdav-1.0-beta-2.pom
                Downloading: http://repository.jboss.org/maven2/org/apache/maven/wagon/wagon-web
                dav/1.0-beta-2/wagon-webdav-1.0-beta-2.pom
                Downloading: http://repo1.maven.org/maven2/org/apache/maven/wagon/wagon-webdav/1
                .0-beta-2/wagon-webdav-1.0-beta-2.pom
                Downloading: http://download.java.net/maven/1/org.codehaus.plexus/poms/plexus-ut
                ils-1.1.pom
                Downloading: http://repository.jboss.org/maven2/org/codehaus/plexus/plexus-utils
                /1.1/plexus-utils-1.1.pom
                Downloading: http://repo1.maven.org/maven2/org/codehaus/plexus/plexus-utils/1.1/
                plexus-utils-1.1.pom
                Downloading: http://download.java.net/maven/1/org.apache.maven.wagon/jars/wagon-
                webdav-1.0-beta-2.jar
                Downloading: http://repository.jboss.org/maven2/org/apache/maven/wagon/wagon-web
                dav/1.0-beta-2/wagon-webdav-1.0-beta-2.jar
                Downloading: http://repo1.maven.org/maven2/org/apache/maven/wagon/wagon-webdav/1
                .0-beta-2/wagon-webdav-1.0-beta-2.jar
                Downloading: http://download.java.net/maven/1/org.codehaus.plexus/jars/plexus-ut
                ils-1.1.jar
                Downloading: http://repository.jboss.org/maven2/org/codehaus/plexus/plexus-utils
                /1.1/plexus-utils-1.1.jar
                Downloading: http://repo1.maven.org/maven2/org/codehaus/plexus/plexus-utils/1.1/
                plexus-utils-1.1.jar
                [INFO] ------------------------------------------------------------------------
                [ERROR] BUILD ERROR
                [INFO] ------------------------------------------------------------------------
                [INFO] Failed to resolve artifact.
                
                Missing:
                ----------
                1) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.apache.maven.wagon -DartifactId=wag
                on-webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file
                
                 Alternatively, if you host your own repository you can deploy the file there:
                
                 mvn deploy:deploy-file -DgroupId=org.apache.maven.wagon -DartifactId=wagon
                -webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -D
                repositoryId=[id]
                
                 Path to dependency:
                 1) org.richfaces:framework:pom:3.3.0.GA
                 2) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
                
                2) org.codehaus.plexus:plexus-utils:jar:1.1
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.codehaus.plexus -DartifactId=plexus
                -utils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file
                
                 Alternatively, if you host your own repository you can deploy the file there:
                
                 mvn deploy:deploy-file -DgroupId=org.codehaus.plexus -DartifactId=plexus-u
                tils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -Drepository
                Id=[id]
                
                 Path to dependency:
                 1) org.richfaces:framework:pom:3.3.0.GA
                 2) org.codehaus.plexus:plexus-utils:jar:1.1
                
                ----------
                2 required artifacts are missing.
                
                for artifact:
                 org.richfaces:framework:pom:3.3.0.GA
                
                from the specified remote repositories:
                 central (http://repo1.maven.org/maven2),
                 repository.jboss.org (http://repository.jboss.org/maven2),
                 maven-repository.dev.java.net (http://download.java.net/maven/1)
                
                
                
                [INFO] ------------------------------------------------------------------------
                [INFO] Trace
                org.apache.maven.lifecycle.LifecycleExecutionException: Missing:
                ----------
                1) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.apache.maven.wagon -DartifactId=wag
                on-webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file
                
                 Alternatively, if you host your own repository you can deploy the file there:
                
                 mvn deploy:deploy-file -DgroupId=org.apache.maven.wagon -DartifactId=wagon
                -webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -D
                repositoryId=[id]
                
                 Path to dependency:
                 1) org.richfaces:framework:pom:3.3.0.GA
                 2) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
                
                2) org.codehaus.plexus:plexus-utils:jar:1.1
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.codehaus.plexus -DartifactId=plexus
                -utils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file
                
                 Alternatively, if you host your own repository you can deploy the file there:
                
                 mvn deploy:deploy-file -DgroupId=org.codehaus.plexus -DartifactId=plexus-u
                tils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -Drepository
                Id=[id]
                
                 Path to dependency:
                 1) org.richfaces:framework:pom:3.3.0.GA
                 2) org.codehaus.plexus:plexus-utils:jar:1.1
                
                ----------
                2 required artifacts are missing.
                
                for artifact:
                 org.richfaces:framework:pom:3.3.0.GA
                
                from the specified remote repositories:
                 central (http://repo1.maven.org/maven2),
                 repository.jboss.org (http://repository.jboss.org/maven2),
                 maven-repository.dev.java.net (http://download.java.net/maven/1)
                
                
                 at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(De
                faultLifecycleExecutor.java:166)
                 at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
                fecycleExecutor.java:140)
                 at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
                 at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
                 at org.apache.maven.cli.MavenCli.main(MavenCli.java:301)
                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
                java:39)
                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
                sorImpl.java:25)
                 at java.lang.reflect.Method.invoke(Method.java:585)
                 at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
                 at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
                 at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
                
                 at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
                Caused by: org.apache.maven.artifact.resolver.MultipleArtifactsNotFoundException
                : Missing:
                ----------
                1) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.apache.maven.wagon -DartifactId=wag
                on-webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file
                
                 Alternatively, if you host your own repository you can deploy the file there:
                
                 mvn deploy:deploy-file -DgroupId=org.apache.maven.wagon -DartifactId=wagon
                -webdav -Dversion=1.0-beta-2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -D
                repositoryId=[id]
                
                 Path to dependency:
                 1) org.richfaces:framework:pom:3.3.0.GA
                 2) org.apache.maven.wagon:wagon-webdav:jar:1.0-beta-2
                
                2) org.codehaus.plexus:plexus-utils:jar:1.1
                
                 Try downloading the file manually from the project website.
                
                 Then, install it using the command:
                 mvn install:install-file -DgroupId=org.codehaus.plexus -DartifactId=plexus
                -utils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file
                
                 Alternatively, if you host your own repository you can deploy the file there:
                
                 mvn deploy:deploy-file -DgroupId=org.codehaus.plexus -DartifactId=plexus-u
                tils -Dversion=1.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -Drepository
                Id=[id]
                
                 Path to dependency:
                 1) org.richfaces:framework:pom:3.3.0.GA
                 2) org.codehaus.plexus:plexus-utils:jar:1.1
                
                ----------
                2 required artifacts are missing.
                
                for artifact:
                 org.richfaces:framework:pom:3.3.0.GA
                
                from the specified remote repositories:
                 central (http://repo1.maven.org/maven2),
                 repository.jboss.org (http://repository.jboss.org/maven2),
                 maven-repository.dev.java.net (http://download.java.net/maven/1)
                
                
                 at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
                nsitively(DefaultArtifactResolver.java:324)
                 at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
                nsitively(DefaultArtifactResolver.java:288)
                 at org.apache.maven.extension.DefaultExtensionManager.addExtension(Defau
                ltExtensionManager.java:132)
                 at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(De
                faultLifecycleExecutor.java:158)
                 ... 12 more
                [INFO] ------------------------------------------------------------------------
                [INFO] Total time: 4 minutes 13 seconds
                [INFO] Finished at: Thu Apr 09 15:49:00 EDT 2009
                [INFO] Final Memory: 1M/3M
                [INFO] ------------------------------------------------------------------------
                C:\richfaces-ui-3.3.0.GA\framework>


                • 5. Re: Building Richfaces 3.3.0
                  Ilya Shaikovsky Master

                  please read about additional maven configuration.
                  http://www.jboss.org/community/docs/DOC-9930