0 Replies Latest reply on Feb 26, 2004 7:39 AM by martin_graney

    Installation issues with Mac OS X 10.3.2 and JBoss 3.2.3

    martin_graney Newbie

      Hi All

      I am trying to install, get working, JBoss 3.2.3 on a Mac OS X 10.3.2 machine [Not Server] and have come across something that looks like a classpath issue.
      The following is the head of the log o/p

      ================================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /usr/local/jboss/jboss-3.2.3

      JAVA: /usr/bin/java

      JAVA_OPTS: -Dprogram.name=run.sh

      CLASSPATH: /usr/local/jboss/jboss-3.2.3/bin/run.jar:/lib/tools.jar

      ================================================================================

      13:42:35,655 INFO [Server] Starting JBoss (MX MicroKernel)...
      13:42:35,687 INFO [Server] Release ID: JBoss [WonderLand] 3.2.3 (build: CVSTag=JBoss_3_2_3 date=200311301445)
      13:42:35,693 INFO [Server] Home Dir: /usr/local/jboss/jboss-3.2.3
      13:42:35,695 INFO [Server] Home URL: file:/usr/local/jboss/jboss-3.2.3/
      13:42:35,699 INFO [Server] Library URL: file:/usr/local/jboss/jboss-3.2.3/lib/
      13:42:35,724 INFO [Server] Patch URL: null
      13:42:35,761 INFO [Server] Server Name: default
      13:42:35,764 INFO [Server] Server Home Dir: /usr/local/jboss/jboss-3.2.3/server/default
      13:42:35,768 INFO [Server] Server Home URL: file:/usr/local/jboss/jboss-3.2.3/server/default/
      13:42:35,770 INFO [Server] Server Data Dir: /usr/local/jboss/jboss-3.2.3/server/default/data
      13:42:35,773 INFO [Server] Server Temp Dir: /usr/local/jboss/jboss-3.2.3/server/default/tmp
      13:42:35,776 INFO [Server] Server Config URL: file:/usr/local/jboss/jboss-3.2.3/server/default/conf/
      13:42:35,779 INFO [Server] Server Library URL: file:/usr/local/jboss/jboss-3.2.3/server/default/lib/
      13:42:35,782 INFO [Server] Root Deployment Filename: jboss-service.xml
      13:42:35,925 INFO [Server] Starting General Purpose Architecture (GPA)...
      13:42:37,454 INFO [ServerInfo] Java version: 1.4.2_03,Apple Computer, Inc.
      13:42:37,458 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.2-34,"Apple Computer, Inc."
      13:42:37,461 INFO [ServerInfo] OS-System: Mac OS X 10.3.2,ppc
      13:42:37,728 INFO [ServiceController] Controller MBean online
      13:42:38,318 INFO [MainDeployer] Started jboss.system:service=MainDeployer
      13:42:38,939 INFO [MainDeployer] Adding deployer: org.jboss.deployment.JARDeployer@87955b
      13:42:39,000 INFO [JARDeployer] Started jboss.system:service=JARDeployer
      13:42:39,169 INFO [MainDeployer] Adding deployer: org.jboss.deployment.SARDeployer@ff87dc
      13:42:39,215 INFO [SARDeployer] Started jboss.system:service=ServiceDeployer
      13:42:39,219 INFO [Server] Core system initialized
      13:42:39,330 INFO [MainDeployer] Starting deployment of package: file:/usr/local/jboss/jboss-3.2.3/server/default/conf/jboss-service.xml
      13:42:39,826 ERROR [MainDeployer] Could not initialise deloyment: file:/usr/local/jboss/jboss-3.2.3/server/default/conf/jboss-service.xml
      java.lang.NoClassDefFoundError: org/w3c/dom/ranges/DocumentRange
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)

      ... etc)


      This looks to me like the xercesImpl.jar is not being picked up by the classpath.
      However it is definitely in the jboss/lib/ dir.


      Anyone know what is going on here? is it some quirky macosx jvm issue?

      Martin G