4 Replies Latest reply on Jun 8, 2004 1:24 AM by saroj

    Possible bug in JBoss 3.2.3

    Armenio Pinto Newbie

      Hi there,

      I'm noticing a strange behaviour in JBoss 3.2.3. When an undeployment is immediatly followed be a deployment, the following exception occurs:

      Caused by: java.lang.NullPointerException
      at org.jboss.mx.loading.LoadMgr3.beginLoadTask(LoadMgr3.java:119)
      at org.jboss.mx.loading.UnifiedClassLoader3.loadClassImpl(UnifiedClassLoader3.java:169)
      at org.jboss.mx.loading.UnifiedClassLoader3.loadClass(UnifiedClassLoader3.java:123)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:140)
      at oracle.net.ns.NetException.(Unknown Source)
      at oracle.net.ano.Ano.e(Ano)
      at oracle.net.ano.Ano.init(Ano)
      at oracle.net.ns.NSProtocol.connect(Unknown Source)
      at oracle.jdbc.ttc7.TTC7Protocol.connect(TTC7Protocol.java:1774)
      at oracle.jdbc.ttc7.TTC7Protocol.logon(TTC7Protocol.java:215)
      at oracle.jdbc.driver.OracleConnection.(OracleConnection.java:362)
      at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:536)
      at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:328)
      at org.jboss.resource.adapter.jdbc.local.LocalManagedConnectionFactory.createManagedConnection(LocalManagedConnectionFactory.java:150)
      ... 44 more


      In the application, I'm trying to create a connection from a DataSource to an Oracle database. I've inspected LoadMgr3.java:119 and a NPE can only occur if "task" or "repository" are null. Has anyone experienced the same error? Thanks in advance,

      Arménio Pinto