0 Replies Latest reply on Mar 16, 2004 2:34 AM by Manu

    ClassLoading problems while configuring JASPER

    Manu Newbie

      Hi All,

      I am using jboss-3.0.4_tomcat-4.1.12 veriosn.

      I am trying to use JASPER to generate pdf reports in my EJB.

      Jasper uses commons-digester.jar which is used by calatina and is already present in the tomcat4.1.x/server/lib directory.

      However when I try to access jasper through my EJB, I get the following error:
      java.lang.NoClassDefFoundError: org/apache/commons/digester/Digester

      When I see the UnifiedClassLoader repository through my jmx-console, I can see the commons-digester.jar in list of already deployed URLs. As per my understanding based on JBOSS documnetation, if the jar is deployed in the UCL Repository, it shud be accessible to all the deployed applications.

      I have tried the following options but none of them work:
      1. In the EAR file, added a manifest classpath entry.
      2. Included it in the run.bat classpath
      3. Put the jar file in the $JBOSS_HOME/server/default/lib directory.
      4. We also tried it in the JSP in which case we tried the following options:
      a. We added the jar in the web-inf/lib directory
      b. We added a classpath entry in the META-INF/manifest.mf


      Does somebody have a clue how to solve the problem?

      Regards
      Manu