0 Replies Latest reply on Apr 7, 2004 6:11 PM by Leandro Terra Melo

    MySQL works fine on jboss 3.2.3, but not on jboss 3.2.1

    Leandro Terra Melo Newbie

      Hi,
      i configured jboss 3.2.3 perfectly to use mysql as DefaultDS, works fine.
      Then, i tried to do the same with jboss 3.2.1, but doesn't work (get a lot of exceptions in initialization).
      Here is what i did to configure mysql in jboss 3.2.3 (THIS WORKS)
      - Replaced hsqldb-ds.xml by mysql-ds.xml and edited jndi-name (put
      DefaultDS).
      - Edited standardjbosscmp-jdbc.xml and put mySQL as the datasource
      mapping, also set fk-constraint to true.
      - Edited standardjaws.xml and set the type-mapping as mySQL
      - Replaced hsql-jdbc2-service.xml by mysql-jdbc2-service.xml and
      changed MySqlDS to DefaultDS in this file
      - Edited login-config.xml and added the following block of code

      <application-policy name = "MySqlDbRealm">

      <login-module code
      = "org.jboss.resource.security.ConfiguredIdentityLoginModule"
      flag = "required">
      <module-option name = "principal">jboss</module-option>
      <module-option name = "userName">jboss</module-option>
      <module-option name = "password">11223344</module-option>
      <module-option name
      = "managedConnectionFactoryName">jboss.jca:service=LocalTxCM,name =DefaultDS</module-option>
      </login-module>

      </application-policy>


      With this, everything worked fine on jboss 3.2.3. Then, I did the exact same steps on jboss 3.2.1, except the part of the file hsql-jdbc2-service.xml wich doesn't exist in jboss 3.2.1.

      When i run jboss 3.2.1 with this configuration I get exceptions raised.
      Does anyone have any idea????