1 Reply Latest reply on Sep 7, 2004 5:14 PM by neil upfalow

    JBoss and NAT Problem

    vng78 Newbie

      All,

      I've been following the Firewall & NAT thing for a while and I'm still not
      getting a more definitive answer here. I'm trying to connect a client (Swing) via dialup to JBoss behind a NAT router.

      The first thing the client does is to get the Topic from Jboss. It can get
      the TopicConnectionFactory but when getting to the Topic, it just hangs there. Trace from the client shows that it's trying to connect to server's internal IP at port 8090. I tried -Djava.rmi.server.hostname and stuff like that. Nothing worked. I also setup my jms-ds.xml according to Adrian's FAQ to setup the remote connection pool and use UIL2XAConnectionFactory. From client trace, I can still see it's using OILServiceIL... What am I missing?

      Now, I know this may not be JBoss' fault and it's just how RMI behaves and all, but I just need to know if and how I can overcome this problem.
      I would deeply appreciate if anyone could redirect me to some FAQ or just shed some light.

      Thanks!