2 Replies Latest reply on Apr 23, 2004 5:04 AM by cari34

    Problem when starting JBOSS on Unix

    cari34 Newbie

      hi guys,
      I have a problem when trying to start JBOSS on Unix.

      I have the following error :

      14:30:30,992 ERROR [Server] Failed to start
      java.lang.RuntimeException: Unable to create the MBean server instance. Class org.jboss.mx.server.MBeanServerImpl has raised an exception in constructor: java.lang.NoSuchFieldError: org.jboss.mx.modelmbean.ModelMBeanInvoker: field ALL_DESCRIPTORS not found
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:180)
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:80)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:327)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:388)
      at java.lang.Thread.run(Thread.java:512)
      Failed to boot JBoss:
      java.lang.RuntimeException: Unable to create the MBean server instance. Class org.jboss.mx.server.MBeanServerImpl has raised an exception in constructor: java.lang.NoSuchFieldError: org.jboss.mx.modelmbean.ModelMBeanInvoker: field ALL_DESCRIPTORS not found
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:180)
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:80)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:327)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:388)
      at java.lang.Thread.run(Thread.java:512)

      I use JDK 1.3.1 and JBOSS 3.2.2 on AIX 4.3.

      Has anyone any idea how could I get it work ?

      Thank you

      Cari34

        • 1. Re: Problem when starting JBOSS on Unix
          Darran Lofthouse Master

          Try a 1.4 JDK or I think JBoss might need to be compiled with the 1.3 JDK

          • 2. Re: Problem when starting JBOSS on Unix
            cari34 Newbie

            hi derranl,
            Thanks for your reply.
            I recompiled the JBOSS sources using the JDK 1.3.
            Now I get the following error.

            09:38:02,616 WARN [ServiceController] Problem starting service jboss.web:service=WebServer
            java.lang.ExceptionInInitializerError:
            java.util.MissingResourceException: Can't find bundle for base name org.apache.catalina.startup.LocalStrings, locale en
            at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java(Compiled Code))
            at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java(Compiled Code))
            at java.util.ResourceBundle.getBundle(ResourceBundle.java:557)
            at org.apache.catalina.util.StringManager.(StringManager.java:115)
            at org.apache.catalina.util.StringManager.getManager(StringManager.java:260)
            at org.apache.catalina.startup.Embedded.(Embedded.java:248)
            at java.lang.Class.forName1(Native Method)


            Does anyone experianced the same error on Unix machine ?

            Thank you.

            Stan.