2 Replies Latest reply on Nov 10, 2005 8:00 AM by Andrei Karneyenka

    JBoss startup error.

    elfuhrer Novice

      I have been using JBoss for almost 2 years now, but what I'm facing right now is really weird. The first time I start JBoss everything goes fine, however if I shutdown the server and start it back again, JBoss can't bind to the following ports 1098, 4444 and 8080. I get a huge stack of exceptions regarding those services and nothing starts properly.
      Now if I wait for a while everything is normal back again.
      I'm using JBoss 3.2.3 (Production) and J2SDK 1.4.2_04. Has anybody faced this issue so far?
      Best Regards,
      Fady

        • 1. Re: JBoss startup error.
          elfuhrer Novice

          Well the problem is solved. It turned out to be that all of this mess is cause by the ISA firewall client. Disable it before running the JBoss server

          • 2. Re: JBoss startup error.
            Andrei Karneyenka Newbie

            The same problem on 4.0.3 SP1.

            It doesnt seem to be the best solution around, as company's security policy won't allow you to disable that firewall.

            I've found another solution though -

            you have to remove _ALL_ ${jboss.bind.address} encounters from jboss-service.xml:


             <attribute name="Port">1099</attribute>
             <attribute name="BindAddress">${jboss.bind.address}</attribute>
             <attribute name="RmiPort">5098</attribute>
             <attribute ame="RmiBindAddress">${jboss.bind.address}</attribute>
            

            to:
             <attribute name="Port">1099</attribute>
             <attribute name="RmiPort">5098</attribute>