1 Reply Latest reply on Apr 28, 2004 12:46 PM by lordcoven

    shutdown hangs

    lordcoven Newbie

      Well, I haven't had this one before. When I shutdown a server I configured (although I hardly did anything - just added some JMS queues to the default config, and that's been working dandy before today anyway) it hangs at the point illustrated further below. This all happened after I configured a PostgreSQL DS. I've since removed the DS again, but the problem remains.
      Can anyone shed any light on this?
      Cheers,
      C


      21:21:32,375 INFO [PluginManager] Stopping jboss.admin:service=PluginManager
      21:21:32,407 INFO [InvokerAdaptorService] Stopping jboss.jmx:type=adaptor,name=Invoker
      21:21:32,410 INFO [NamingAlias] Stopping jboss.jmx:alias=jmx/rmi/RMIAdaptor
      21:21:32,412 INFO [JRMPProxyFactory] Stopping jboss.jmx:type=adaptor,name=Invoker,protocol=jrmp,service=proxyFactory
      21:21:32,496 INFO [EmbeddedTomcatService] undeploy, ctxPath=/jbossmq-httpil, warUrl=file:/usr/local/jboss-3.2.3/server/pqm/deploy/jms/jbossmq-httpil.sar/jbossmq-httpil.war/
      21:21:32,499 INFO [Engine] StandardHost[localhost]: Removing web application at context path /jbossmq-httpil
      21:21:32,538 INFO [EmbeddedTomcatService] undeploy, ctxPath=/invoker, warUrl=file:/usr/local/jboss-3.2.3/server/pqm/deploy/http-invoker.sar/invoker.war/
      21:21:32,542 INFO [Engine] StandardHost[localhost]: Removing web application at context path /invoker
      21:21:32,605 INFO [EmbeddedTomcatService] Stopping jboss.web:service=WebServer
      21:21:32,608 INFO [MainDeployer] Removing deployer: org.jboss.web.tomcat.tc4.EmbeddedTomcatService@291d49
      21:21:32,614 INFO [Http11Protocol] Stoping http11 protocol on 8080 null

        • 1. Re: shutdown hangs
          lordcoven Newbie

          Well - I've got it working again. Very, very odd. I moved all four JARs I'd added out of the lib and deploy directories, removed all temporary and working files, then tried. It worked. Then I added them in one after another each time trying - and I was able to shut down cleanly each time. It must have just been some working or temporary file that had gotten its knickers in a twist! :/

          Cheers,
          C