2 Replies Latest reply on Apr 29, 2004 5:15 AM by cari34

    Problem with JBOSS on UNIX

    cari34 Newbie

      Hi guys,
      I have a problem when starting JBOSS on UNIX AIX 4.3
      I get the follwing exception when jbossweb-tomcat41.sar
      has to be deployed

      595 ERROR [org.jboss.deployment.MainDeployer] Could not initialise deloyment: file:/usr/probin/jboss-3.2.3/server/default/deploy/jbossweb-tomcat41.sar/
      org.jboss.deployment.DeploymentException: Could not deploy sub deployment jakarta-regexp-1.2.jar of deployment file:/usr/probin/jboss-3.2.3/server/default/deploy/jbossweb-tomcat41.sar/; - nested throwable: (org.jboss.deployment.DeploymentException: url file:/usr/probin/jboss-3.2.3/server/default/deploy/jbossweb-tomcat41.sar/jakarta-regexp-1.2.jar could not be opened, does it exist?)
      at org.jboss.deployment.SubDeployerSupport.deployUrl(SubDeployerSupport.java(Compiled Code))

      I use IBM JDK 1.3.1 on AIX 4.3
      Do you have any idea what is going on and how could I fix it ?

      Thank you very much
      Cari

        • 1. Re: Problem with JBOSS on UNIX
          Darran Lofthouse Master

          I am not sure about the IBM JDK but I think generally JBoss 3.2.3 needs to be recompiled with the 1.3 JDK if you are going to use it to run JBoss.

          There is a release candidate for JBoss 3.2.4 compiled with a 1.3 JDK you could give that a go to see if it is any better.

          • 2. is JBOSS 3.2.3 on UNIX compatible with IBM JDK 1.3.1
            cari34 Newbie

            Hi, guys, hi darranl,
            Thanks for the reply.
            I would like to know if JBOSS 3.2.3 release on UNIX is
            compatible with the IBM JDK 1.3.1 on AIX 4.3.
            When I start JBOSS I get the following error

            WARN [org.jboss.system.ServiceController] Problem starting service jboss.web:service=WebServer
            java.lang.ExceptionInInitializerError:
            java.util.MissingResourceException: Can't find bundle for base name org.apache.catalina.startup.LocalStrings, locale fr_FR
            at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java(Compiled Code))

            I have separate Tomcat 4.1 running on the same system and
            starts whitout any error.

            Does anyone know where the problem could be ?

            Thank you very much
            Cari 34