8 Replies Latest reply on Jun 17, 2004 7:28 PM by Sascha Kulawk

    URGENT- Classloader issue

    vivkap01 Newbie

      Hi
      We are migrating to JBOSS and have stumbled across many classloading issues.
      We are using the JBOSS 3.2.3 and have not change any configuration, so its all the default settings.
      We had a war file which worked with Weblogic , Orion and Tomcat , but fails miserably with JBOSS at several places.

      Firstly we had problems because we use JDOM. This is the error I got

      14:27:22,793 ERROR [LogInterceptor] Unexpected Error:
      java.lang.NoClassDefFoundError: org/saxpath/SAXPathException
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:141)
      at org.jdom.xpath.XPath.newInstance(XPath.java:133)
      at ch.argentis.base.xml.JXmlHelper.getValue(JXmlHelper.java:167)

      I saw the same error in an earlier post , and so I thought of making a change in JDOM source. But then I saw jdom.jar used by JBOSS too, and because of classloading hierarchy it is this jdom.jar that would be used. Though I know there might be some setting so that the applications jdom.jar would be used rather than JBOSS's , my question is how come it works with three other servers and fails only with JBOSS.
      Secondly I have log4j.properties file under WEB-INF/classes inside my war file. Any application server is supposed to find .properties file WEB-INF/classes because this should be in the classpath. But this does not seem to work, JBOSS is not finding the .properties file. Again it works just fine with other servers.
      Do I have to tweak the default settings in JBOSS to get these things to work ? Will the later version of JBOSS fix these issues so that it works by default ?
      I have spend lot of time reading various documents and trying different things, and have reached a frustration level, trying to deploy a simple war file.
      I would appreciate any help for this. Thanks
      --Viv