5 Replies Latest reply on Jun 18, 2004 10:05 AM by Pedro Nevado

    Debug messages in Log

    amenosse Newbie

      Hi,

      I'm using JBoss3.2.4 and it is generate a lot of debug messages in Log.

      How can I disable debug messages ?

      Thanks.

      André Menosse.

        • 1. Re: Debug messages in Log
          kirkh Newbie

          There is a log4j.xml file in the conf directory of the server version you are running (all, debug, minimal). Change any reference in there using the words INFO or DEBUG to WARN or ERROR or FATAL depending on how much debugging and error handling you want to turn off. A quick perusal through the Apache log4j guide will be very helpful.

          FYI: the output order (most to least) is:
          DEBUG, INFO, WARN, ERROR, FATAL

          • 2. Re: Debug messages in Log
            amenosse Newbie

            Ok, kirkh.

            I changed the log4j.xml, but the debug messages are in log yet.
            Rebember that I'm using JBoss 3.2.4 (Default). I search this configuration in all objects but I didn't find it.

            What more can I do ?

            Thanks.

            • 3. Re: Debug messages in Log
              amenosse Newbie

              I can't disable the messages in log of JBoss 3.2.4.

              These are the messages:

              deployer: org.jboss.deployment.SARDeployer@12bb7e0
              status: null
              state: INIT_DEPLOYER
              watch: file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/META-INF/jboss-service.xml
              lastDeployed: 0
              lastModified: 0
              mbeans:
              ]
              2004-06-18 09:45:33,218 DEBUG [org.jboss.deployment.DeploymentInfo] createLoaderRepository from config: LoaderRepositoryConfig(repositoryName: JMImplementation:service=LoaderRepository,name=Default, repositoryClassName: null, configParserClassName: null, repositoryConfig: null)
              2004-06-18 09:45:33,218 DEBUG [org.jboss.mx.loading.UnifiedClassLoader] New jmx UCL with url file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/
              2004-06-18 09:45:33,218 DEBUG [org.jboss.mx.loading.UnifiedClassLoader] setRepository, r=org.jboss.mx.loading.UnifiedLoaderRepository3@5e5a50, ucl=org.jboss.mx.loading.UnifiedClassLoader3@1bbdd48{ url=file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ ,addedOrder=0}
              2004-06-18 09:45:33,218 DEBUG [org.jboss.mx.loading.UnifiedClassLoader] setRepository, r=org.jboss.mx.loading.UnifiedLoaderRepository3@5e5a50, ucl=org.jboss.mx.loading.UnifiedClassLoader3@1bbdd48{ url=file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ ,addedOrder=0}
              2004-06-18 09:45:33,218 DEBUG [org.jboss.mx.loading.UnifiedLoaderRepository3] Adding org.jboss.mx.loading.UnifiedClassLoader3@1bbdd48{ url=file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ ,addedOrder=0}
              2004-06-18 09:45:33,218 DEBUG [org.jboss.mx.loading.ClassLoaderUtils] Multiple class loaders found for pkg:
              2004-06-18 09:45:33,234 DEBUG [org.jboss.deployment.MainDeployer] found 27 subpackages of file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/
              2004-06-18 09:45:33,234 DEBUG [org.jboss.deployment.MainDeployer] Starting deployment (init step) of package at: file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ant.jar
              2004-06-18 09:45:33,234 DEBUG [org.jboss.deployment.MainDeployer] Copying file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ant.jar -> D:\J2EE\jboss-3.2.4\server\default\tmp\deploy\tmp41601ant.jar
              2004-06-18 09:45:33,343 DEBUG [org.jboss.deployment.JARDeployer] No xml files found
              2004-06-18 09:45:33,359 DEBUG [org.jboss.deployment.MainDeployer] using deployer org.jboss.deployment.JARDeployer@e80842
              2004-06-18 09:45:33,359 DEBUG [org.jboss.deployment.JARDeployer] looking for nested deployments in : file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ant.jar
              2004-06-18 09:45:33,406 DEBUG [org.jboss.management.j2ee.LocalJBossServerDomain] handleNotification: javax.management.Notification[source=jboss.system:service=JARDeployer,type=org.jboss.deployment.SubDeployer.init,sequenceNumber=3,timeStamp=1087562733406,message=null,userData=org.jboss.deployment.DeploymentInfo@bd0b2692 { url=file:/D:/J2EE/jboss-3.2.4/server/default/deploy/jbossweb-tomcat50.sar/ant.jar }

              • 4. Re: Debug messages in Log
                Darran Lofthouse Master

                You need to go to http://logging.apache.org/log4j/docs/ and read the documentation on how to configure Log4j

                • 5. Re: Debug messages in Log
                  Pedro Nevado Newbie

                  I added this line to the

                  <param name="Threshold" value="INFO"/>


                  to the
                  <appender name="FILE" class="org.jboss.logging.appender.DailyRollingFileAppender">


                  in the log4j.xml file. It worked for me.