8 Replies Latest reply on Sep 23, 2004 7:13 AM by Jordi Casas

    jboss-3.2.4:NoSuchMethodError: org.jaxen.BaseXPath.<init>(Lj

    laverite Newbie

      I've tried moving an application I have running in jboss-3.2.2RC4 to jboss-3.2.4 and now whenever i run my applications i get the error below. I believe this has something to do with the dom4j jar that is used in the new version. I've tried replacing the dom4j with a newer version from sourceforce- no dice. I'm using jdom and jaxen if that helps anyone help me out....please assist!


      2004-06-24 10:37:07,799 ERROR [org.jboss.ejb.plugins.LogInterceptor] Unexpected Error:
      java.lang.NoSuchMethodError: org.jaxen.BaseXPath.(Ljava/lang/String;Lorg/jaxen/Navigator;)V
      at org.jaxen.jdom.JDOMXPath.(JDOMXPath.java:103)
      at com.latimes.ims.workflow.WorkflowMDB.getPayloadPath(WorkflowMDB.java:169)
      at com.latimes.ims.workflow.WorkflowMDB.onMessage(WorkflowMDB.java:94)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)