3 Replies Latest reply on Jul 16, 2004 4:37 AM by Herinjaka RABARY

    [Tomcat]NoClassDefFoundError: org/apache/catalina/Context

    Herinjaka RABARY Newbie

      I have these error when I run JBoss

      >>>>>>>>>>>>>>>
      21:59:43,249 INFO [MainDeployer] Deployed package:
      file:/Users/bj/jboss-3.0.3_tomcat-4.1.12/server/default/deploy/tomcat41-service.jar
      21:59:43,293 ERROR [URLDeploymentScanner] Failed to deploy:
      org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL@8b9f3b15{
      url=file:/Users/bj/jboss-3.0.3_tomcat-4.1.12/server/default/deploy/tomcat41-service.xml,
      deployedLastModified=0 }
      org.jboss.deployment.DeploymentException: instantiating
      org.jboss.web.catalina.EmbeddedCatalinaService41 failed:
      java.lang.NoClassDefFoundError: org/apache/catalina/Context; - nested
      throwable: (RuntimeErrorException: instantiating
      org.jboss.web.catalina.EmbeddedCatalinaService41 failed:
      java.lang.NoClassDefFoundError: org/apache/catalina/Context
      Cause: java.lang.NoClassDefFoundError: org/apache/catalina/Context)
       at
      org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:155)
       at
      org.jboss.system.ServiceController.install(ServiceController.java:225)
      <<<<<<<<<<<<<<<
      
      Down at the end it summarizes the problems with:
      
      >>>>>>>>>>>>>>>>
      21:59:44,779 ERROR [URLDeploymentScanner] MBeanException: Exception in
      MBean operation 'checkIncompleteDeployments()'
      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:
      [org.jboss.deployment.DeploymentInfo@4ce8ec52 {
      url=file:/Users/bj/jboss-3.0.3_tomcat-4.1.12/server/default/deploy/http-invoker.sar/invoker.war/
      }
       deployer: null
       status: Starting
       state: INIT_WAITING_DEPLOYER
       watch:
      file:/Users/bj/jboss-3.0.3_tomcat-4.1.12/server/default/deploy/http-invoker.sar/invoker.war/
       lastDeployed: 1035521982764
       lastModified: 1033424080000
       mbeans:
      , org.jboss.deployment.DeploymentInfo@1e0d4679 {
      url=file:/Users/bj/jboss-3.0.3_tomcat-4.1.12/server/default/deploy/jmx-console.war/
      }
       deployer: null
       status: null
       state: INIT_WAITING_DEPLOYER
       watch:
      file:/Users/bj/jboss-3.0.3_tomcat-4.1.12/server/default/deploy/jmx-console.war/
       lastDeployed: 1035521984776
       lastModified: 1033424092000
       mbeans:
      ]Incompletely deployed packages:
      <<<<<<<<<<<<<<<<<
      
      
      



      If I try to launch tomcat in standalone, it's run if I do
      sh /usr/local/jboss/tomcat/bin/catalina.sh
      

      but not if I do
      sh /usr/local/jboss/tomcat/bin/startup.sh
      


      I already have set up the environnement variable : JAVA_HOME, ANT_HOME and CATALINA_HOME.

      I'm trying to find solution since 5 days but I don't find the solution.

      I work with :

      OS : RedHat9
      Java tools :
      J2sdk 1.4.2
      JBoss 3.0.6 with Tomcat 1.4

      PS : With the same tools, I can work and deploy a ejb, war, ear files in Windows Environnement, and jboss work fine. What is the solution of my problem?
      Thank you