3 Replies Latest reply on Jul 20, 2004 3:21 PM by Tim Shaw

    JBoss not starting/booting in RHEL AS 3

    Santhanam Veerasamy Newbie

      Hi Friends,
      We have a new Redhat Enterprise Linux Advanced Server 3. We are now trying to migrate our Redhat Linux 9 based server to new server. When i am trying to start jboss, it is not starting/booting. There is no error. I have tried both Jboss 3.2.3 and Jboss 3.2.5. Both gives the same problem. In RHL 9 they are working perfectly. Please kindly help me.
      Thanks in Advance
      With Regards
      Santhanam

        • 1. Re: JBoss not starting/booting in RHEL AS 3
          Santhanam Veerasamy Newbie

          Here is the output:

          ---------------------------------------


          [root@amtitavidya bin]# ./run.sh
          =========================================================================

          JBoss Bootstrap Environment

          JBOSS_HOME: /usr/local/jboss-3.2.5

          JAVA: /usr/local/j2sdk1.4.1_01/bin/java

          JAVA_OPTS: -server -Dprogram.name=run.sh

          CLASSPATH: /usr/local/jboss-3.2.5/bin/run.jar:/usr/local/j2sdk1.4.1_01/lib/tools.jar

          =========================================================================

          14:17:11,829 INFO [Server] Starting JBoss (MX MicroKernel)...
          14:17:11,831 INFO [Server] Release ID: JBoss [WonderLand] 3.2.5 (build: CVSTag=JBoss_3_2_5 date=200406251954)
          14:17:11,832 INFO [Server] Home Dir: /usr/local/jboss-3.2.5
          14:17:11,832 INFO [Server] Home URL: file:/usr/local/jboss-3.2.5/
          14:17:11,832 INFO [Server] Library URL: file:/usr/local/jboss-3.2.5/lib/
          14:17:11,835 INFO [Server] Patch URL: null
          14:17:11,835 INFO [Server] Server Name: default
          14:17:11,835 INFO [Server] Server Home Dir: /usr/local/jboss-3.2.5/server/default
          14:17:11,836 INFO [Server] Server Home URL: file:/usr/local/jboss-3.2.5/server/default/
          14:17:11,836 INFO [Server] Server Data Dir: /usr/local/jboss-3.2.5/server/default/data
          14:17:11,837 INFO [Server] Server Temp Dir: /usr/local/jboss-3.2.5/server/default/tmp
          14:17:11,837 INFO [Server] Server Config URL: file:/usr/local/jboss-3.2.5/server/default/conf/
          14:17:11,838 INFO [Server] Server Library URL: file:/usr/local/jboss-3.2.5/server/default/lib/
          14:17:11,838 INFO [Server] Root Deployment Filename: jboss-service.xml
          14:17:11,844 INFO [Server] Starting General Purpose Architecture (GPA)...
          14:17:12,158 INFO [ServerInfo] Java version: 1.4.1_01,Sun Microsystems Inc.
          14:17:12,158 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.4.1_01-b01,Sun Microsystems Inc.
          14:17:12,159 INFO [ServerInfo] OS-System: Linux 2.4.21-4.ELsmp,i386
          14:17:12,431 INFO [Server] Core system initialized

          ----------------------------------------

          After this the jboss stands still without giving any messages.

          • 2. Re: JBoss not starting/booting in RHEL AS 3
            Thomas James Malone Newbie

            The problem will lye in your init scrips, as you have no problem starting the server by hand.

            I am having simillar problems with redhat 9, but i have no idea how to set them up.

            • 3. Re: JBoss not starting/booting in RHEL AS 3
              Tim Shaw Newbie

              I've got the same system, and it ran out of the box.

              I would guess that it's your log4j stuff - a snippet from my output goes :

              19:33:17,294 INFO [Server] Root Deployment Filename: jboss-service.xml
              19:33:17,298 INFO [Server] Starting General Purpose Architecture (GPA)...
              19:33:42,982 INFO [ServerInfo] Java version: 1.4.2_04,Sun Microsystems Inc.
              19:33:42,982 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.4.2_04-b05,Sun Microsystems Inc.
              19:33:42,982 INFO [ServerInfo] OS-System: Linux 2.4.21-9.ELsmp,i386
              19:33:43,327 INFO [Server] Core system initialized
              19:33:46,604 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml

              ... and the rest is OK.
              Could also try the later JDK ...

              G'luck

              tim