2 Replies Latest reply on Aug 6, 2004 11:17 AM by Raymond Calbuth

    Problem running JBoss

    Conrad Ottay Newbie

      I run Mac OSX 10.1.5 and I've built JBoss 3.2.5 from the source. My JDK is 1.3.1 and I've set JAVA_HOME to /System/Library/Frameworks/JavaVM.framework/Home as well as /Library/Java/Home. Neither of these work and I've adjusted the run.sh file since the required jar file appears to be classes.jar and not tools.jar. I get the same error no matter what I do. Here it is:
      02:45:51,576 ERROR [Registry] Error loading jar:file:/usr/local/jboss-3.2.5/server/default/tmp/deploy/tmp46223catalina.jar!/org/apache/catalina/startup/mbeans-descriptors.xml
      02:45:51,587 ERROR [Registry] Error loading jar:file:/usr/local/jboss-3.2.5/server/default/tmp/deploy/tmp46223catalina.jar!/org/apache/catalina/mbeans-descriptors.xml
      02:45:51,796 INFO [STDOUT] Error
      02:45:51,800 ERROR [BaseModelMBean] Error creating class java.lang.ExceptionInInitializerError
      02:45:51,812 ERROR [Tomcat5] Starting failed jboss.web:service=WebServer
      ReflectionException: Cannot find setter method setCatalinaHome null
      Cause: java.lang.NoSuchMethodException

      Does someone know what is wrong? Thank you to anyone who can help.

      Conrad