1 Reply Latest reply on Jan 7, 2005 12:04 PM by Matthew Walnock

    Startup on Linux: Permission problem

    Craig Green Newbie

      Hello,
      I'm really hoping that someone out there can point me in the right direction on this one.
      Our server was running fine, we were able to start/stop it without trouble. Then I tried to deploy some new classes which also required an update to jboss-services.xml (I don't deny that I may have unknowingly wreaked havoc somewhere else). Now when I try to start my server I get the error below. I've removed all of my changes and I still get the error. My 'default' server still works ok, I've compared all of the permissions with my 'all' server and they seem to match.

      Thanks,
      -cg

      13:15:00,805 INFO [Server] Core system initialized
      13:15:00,828 INFO [MainDeployer] Starting deployment of package: file:/var/jboss-3.2.3/server/all/conf/jboss-service.xml
      13:15:00,830 ERROR [MainDeployer] Could not make local copy for file:/var/jboss-3.2.3/server/all/conf/jboss-service.xml
      java.io.IOException: Permission denied
      at java.io.UnixFileSystem.createFileExclusively(Native Method)
      at java.io.File.checkAndCreate(File.java:1314)
      at java.io.File.createTempFile(File.java:1402)

        • 1. Re: Startup on Linux: Permission problem
          Matthew Walnock Newbie

          We had the same problem. We run our server as a non-root user. It turns out someone had started the server as root at some point. This had the effect of changing the owner of the <JBOSS_HOME>/server/all/tmp directory tree to root. When you come back to try and start the server as a non-root user, you hit all kinds of permissions problems, this is just the first one you hit.