7 Replies Latest reply on Jan 15, 2009 11:11 AM by Sachin Jain

    Help.  JBoss problems on Mandrake Linux 9.2

    dbostwick Newbie

      ******************************************************************************************************
      ** System: Mandrake Linux 9.2
      ** JDK: 1.4.2_02
      ** JBoss Verions: 3.2.3/3.2.5
      ** JAVA_HOME: /var/java/jdk1.4.2
      ** JBOSS_HOME: Not defined prior to execution of command, Pre-definition produces no visible effect on the results.
      ******************************************************************************************************
      ** My comments preceeded by "**"

      ** JBoss doesn't want to start. I've tried serveral things, but am hoping someone out there with more JBoss experience may have additional clues

      ** The curious thing about this is that JBoss ran at first. The problems started when I added the JBOSS_HOME variable to
      ** /etc/profile, exported it, logged out then back in, and tried to start JBoss again. I have since removed JBOSS_HOME from
      ** /etc/profile, bounced my login, and get the same result. Nothing has worked since.

      ** I started with jboss-3.2.3. This is the one that ran originally, then went kaput. I removed it from the system and gave
      ** jboss-3.2.5 a try. Same problem.

      ** I have had no problems with JBoss (3.2.3, or 3.2.5) on my Win2K SP3 box.

      ** Details follow

      ******************************************************************************************************
      ** JDK: 1.4.2_02
      ******************************************************************************************************

      ** If I run the following command:

      [tech@ducats tech]$ /var/jboss-3.2.5/bin/run.sh -c minimal

      ** I gt the following result:

      =========================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /var/jboss-3.2.5

      JAVA: /var/java/jdk1.4.2/bin/java

      JAVA_OPTS: -server -Dprogram.name=run.sh

      CLASSPATH: /var/jboss-3.2.5/bin/run.jar:/var/java/jdk1.4.2/lib/tools.jar

      =========================================================================

      Failed to boot JBoss:
      java.lang.ClassNotFoundException: org.jboss.system.server.ServerImpl
      at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
      at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:251)
      at org.jboss.system.server.ServerLoader.load(ServerLoader.java:233)
      at org.jboss.Main.boot(Main.java:142)
      at org.jboss.Main$1.run(Main.java:395)
      at java.lang.Thread.run(Thread.java:534)
      [tech@ducats tech]$

      ******************************************************************************************************
      ** JDK: 1.3.1_03
      ** JAVA_HOME: /var/java/jdk1.3.1_03
      ** Sun jmxri.jar, and jmxtools.jar have been placed in the $JAVA_HOME/jre/lib/ext directory
      ******************************************************************************************************
      ** If I change the JDK to 1.3.1_03, modify the JAVA_HOME variable, I get the following result for the same command. Some
      ** of the classpath issues seem to be resoved, but I run into something else:

      [tech@ducats tech]$ /var/jboss-3.2.5/bin/run.sh -c minimal
      =========================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /var/jboss-3.2.5

      JAVA: /var/java/jdk1.3.1_03/bin/java

      JAVA_OPTS: -server -Dprogram.name=run.sh

      CLASSPATH: /var/jboss-3.2.5/bin/run.jar:/var/java/jdk1.3.1_03/lib/tools.jar

      =========================================================================

      17:01:23,243 INFO [Server] Starting JBoss (MX MicroKernel)...
      17:01:23,268 INFO [Server] Release ID: JBoss [WonderLand] 3.2.5 (build: CVSTag=JBoss_3_2_5 date=200406
      1954)
      17:01:23,270 INFO [Server] Home Dir: /var/jboss-3.2.5
      17:01:23,271 INFO [Server] Home URL: file:/var/jboss-3.2.5/
      17:01:23,272 INFO [Server] Library URL: file:/var/jboss-3.2.5/lib/
      17:01:23,277 INFO [Server] Patch URL: null
      17:01:23,278 INFO [Server] Server Name: minimal
      17:01:23,279 INFO [Server] Server Home Dir: /var/jboss-3.2.5/server/minimal
      17:01:23,280 INFO [Server] Server Home URL: file:/var/jboss-3.2.5/server/minimal/
      17:01:23,281 INFO [Server] Server Data Dir: /var/jboss-3.2.5/server/minimal/data
      17:01:23,282 INFO [Server] Server Temp Dir: /var/jboss-3.2.5/server/minimal/tmp
      17:01:23,283 INFO [Server] Server Config URL: file:/var/jboss-3.2.5/server/minimal/conf/
      17:01:23,284 INFO [Server] Server Library URL: file:/var/jboss-3.2.5/server/minimal/lib/
      17:01:23,285 INFO [Server] Root Deployment Filename: jboss-service.xml
      17:01:23,301 INFO [Server] Starting General Purpose Architecture (GPA)...
      17:01:25,086 WARN [BasicMBeanRegistry] javax.management.MBeanRegistrationException: preRegister() fail
      : [ObjectName='JMImplementation:type=MBeanServerDelegate', Class=javax.management.MBeanServerDelegate (
      vax.management.MBeanServerDelegate@2d7a10)]
      javax.management.MBeanRegistrationException: preRegister() failed: [ObjectName='JMImplementation:type=M
      anServerDelegate', Class=javax.management.MBeanServerDelegate (javax.management.MBeanServerDelegate@2d7
      0)]
      at org.jboss.mx.server.registry.BasicMBeanRegistry.invokePreRegister(BasicMBeanRegistry.java:65
      at org.jboss.mx.server.registry.BasicMBeanRegistry.registerMBean(BasicMBeanRegistry.java:199)
      at org.jboss.mx.server.MBeanServerImpl.(MBeanServerImpl.java:192)
      at org.jboss.mx.server.MBeanServerBuilderImpl.newMBeanServer(MBeanServerBuilderImpl.java:56)
      at javax.management.MBeanServerFactory.newMBeanServer(MBeanServerFactory.java:324)
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:227)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:350)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:311)
      at org.jboss.Main.boot(Main.java:145)
      at org.jboss.Main$1.run(Main.java:399)
      at java.lang.Thread.run(Thread.java:479)
      Failed to boot JBoss:
      java.lang.RuntimeException: javax.management.InstanceNotFoundException: JMImplementation:type=MBeanRegistry is not registered.
      at org.jboss.mx.server.MBeanServerImpl.handleInvocationException(MBeanServerImpl.java:1079)
      at org.jboss.mx.server.MBeanServerImpl.registerMBean(MBeanServerImpl.java:1028)
      at org.jboss.mx.server.MBeanServerImpl.registerMBean(MBeanServerImpl.java:326)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:354)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:311)
      at org.jboss.Main.boot(Main.java:145)
      at org.jboss.Main$1.run(Main.java:399)
      at java.lang.Thread.run(Thread.java:479)
      [tech@ducats tech]$

      ******************************************************************************************************
      ** JDK: 1.4.2_02
      ** JAVA_HOME: /var/java/jdk1.4.2
      ******************************************************************************************************
      ** Not wanting to stay with 1.3.1, I attempt to add classpath info to the JBoss start up by adding the following to the run.conf file:

      JBOSS_CLASSPATH="`/var/jboss/bin/classpath.sh -s`"

      ** Note: classpath.sh borrowed from the jboss-3.2.3 release

      ** This solves many of the classpath issues encountered earlier, and I get much farther, but encounter the following error:

      [tech@ducats bin]$ run.sh -c minimal
      =========================================================================

      JBoss Bootstrap Environment

      JBOSS_HOME: /var/jboss

      JAVA: /var/java/jdk1.4.2/bin/java

      JAVA_OPTS: -server -Dprogram.name=run.sh

      CLASSPATH: /var/jboss/lib/xml-apis.jar:/var/jboss/lib/xercesImpl.jar:/var/jboss/lib/webdavlib.jar:/var/jboss/lib/log4j-boot.jar:/var/jboss/lib/jboss-system.jar:/var/jboss/lib/jboss-jmx.jar:/var/jboss/lib/jboss-common.jar:/var/jboss/lib/gnu-regexp.jar:/var/jboss/lib/getopt.jar:/var/jboss/lib/dom4j.jar:/var/jboss/lib/concurrent.jar:/var/jboss/lib/commons-logging.jar:/var/jboss/lib/commons-httpclient.jar:.:/var/java/jdk1.4.2/lib/rt.jar:/var/java/jdk1.4.2/jre/lib/ext/Verisign.jar:/var/java/jdk1.4.2/lib/j2ee.jar:/var/java/jdk1.4.2/jre/lib/jsse.jar:/var/jboss/bin/run.jar:/var/java/jdk1.4.2/lib/tools.jar

      =========================================================================

      java.lang.NoSuchMethodError: org.jboss.mx.server.MBeanServerImpl.(Ljava/lang/String;Ljavax/management/MBeanServer;Ljavax/management/MBeanServerDelegate;)V
      at org.jboss.mx.server.MBeanServerBuilderImpl.newMBeanServer(MBeanServerBuilderImpl.java:56)
      at javax.management.MBeanServerFactory.newMBeanServer(MBeanServerFactory.java:324)
      at javax.management.MBeanServerFactory.createMBeanServer(MBeanServerFactory.java:227)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:350)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:311)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:395)
      at java.lang.Thread.run(Thread.java:534)
      [tech@ducats bin]$

      ** Thanks in advance for any clues.

        • 1. Re: Help.  JBoss problems on Mandrake Linux 9.2
          Anil Saldanha Master

          Dont set JBOSS_HOME in any of your environmental files. There is no need to set it. The run.sh script under jboss/bin will do it for you. Just run that script.

          • 2. Re: Help.  JBoss problems on Mandrake Linux 9.2
            dbostwick Newbie

            ****************************************************
            ** Problem Resolved
            **
            ** Cause:
            **
            ** Faulty SDK installation.
            **
            ** Remedy:
            **
            ** Downloaded and installed self-extracting bin from java.sun.com
            **
            ** j2sdk-1_4_2_05-linunx-i586.bin
            **
            ** Returned run.conf to original, and issued $JBOSS_HOME/bin/run.sh
            ** No problems.
            ****************************************************

            • 3. Re: Help.  JBoss problems on Mandrake Linux 9.2
              arul jose Newbie

              I face the same problem now.

              I removed the JBOSS_HOME from my .bashrc

              I know my jdk installation is proper. I am running tomcat with it.

              I am using mandriva linux (the mandrake version after 10).

              The server is not starting.

              All I have done is just unzipping the jboss zip file and included the jdk/lib/tools.jar in the classpath. [JAVA_HOME is already there].

              Should I do anything more?

              Kindly try to help me.

              Regards,
              ARUL JOSE

              • 4. Re: Help.  JBoss problems on Mandrake Linux 9.2
                arul jose Newbie

                I was using jboss3.2.1 with jdk1.5. i think this is the problem.

                When I changed the jboss version to the latest, its starting fine.

                Regards,
                ARUL JOSE

                • 5. Re: Help.  JBoss problems on Mandrake Linux 9.2
                  Sachin Jain Newbie


                  Hey i am using JBOSS 4.0.5CR1
                  with jdk 1.4
                  but when i tried to run for default i found that JBOSS-SERVICE.xml in conf directory is empty
                  but when i tried to run JBOSS with all configuration
                  JBOSS startup fails showing these exceptions



                  =========================================================================
                  
                   JBoss Bootstrap Environment
                  
                   JBOSS_HOME: /sagit_1/sachin/Desktop/jboss-4.0.5.CR1
                  
                   JAVA: /sagit_1/sachin/Desktop/transferred/sachin/j2sdk1.4.2_09/bin/java
                  
                   JAVA_OPTS: -Dprogram.name=run.sh -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
                  
                   CLASSPATH: /sagit_1/sachin/Desktop/jboss-4.0.5.CR1/bin/run.jar:/sagit_1/sachin/Desktop/transferred/sachin/j2sdk1.4.2_09/lib/tools.jar
                  
                  =========================================================================
                  
                  Failed to boot JBoss:
                  java.lang.ClassNotFoundException: org.jboss.system.server.ServerImpl
                   at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
                   at java.security.AccessController.doPrivileged(Native Method)
                   at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
                   at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
                   at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
                   at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:285)
                   at org.jboss.system.server.ServerLoader.load(ServerLoader.java:267)
                   at org.jboss.Main.boot(Main.java:194)
                   at org.jboss.Main$1.run(Main.java:464)
                   at java.lang.Thread.run(Thread.java:534)
                  


                  • 6. Re: Help.  JBoss problems on Mandrake Linux 9.2
                    Peter Johnson Master

                    sachin1506, please do not resurrect 3 year old posts. And changing the font to a larger size is a sure way to get people to ignore your post.

                    • 7. Re: Help.  JBoss problems on Mandrake Linux 9.2
                      Sachin Jain Newbie

                      Hello sir ...I am sorry for that
                      but changing the font size wasn't my intension that happenned prbbly by mistake