0 Replies Latest reply on Aug 25, 2004 1:43 PM by jjm

    How to serve files with Apache that were deployed from a .WA

    jjm Newbie

      Hello,

      I had posted this to the "HTTPD, Servlets & JSP" (http://www.jboss.org/index.html?module=bb&op=viewtopic&t=53246) and have had no response yet. Please excuse me if re-posting is against ettiquite.

      I would like to know if this is possible. We have a web application that is packaged up and deployed in JBoss as a .WAR file. We would like to serve the static (images, javascript, css, html, etc) using the Apache HTTPD server. Is there any way to control where the .WAR file is unarchived so that the files can be referenced via an Alias, or by setting the Directory Root?

      Currently, I have manually unarchived the .WAR and configured Apache to use the known directory. While this works, it would be nice to not have to "deploy" our application twice!

      Any comments?

      Thanks,
      Josh

      Below is my original post, in case I have left any relevant information out.

      ---------------------------

      As all of these types of posts start, I'm new to JBoss and need some help.

      I have setup Apache 2.0.50 and JBoss 3.2.5 using mod_jk2.

      My application is defined to operate in the root context (http://servername/) by creating a WEB-INF/jboss-web.xml

      I am serving static files (with apache) from a directory off the file system, by setting the DirectoryRoot variable in httpd.conf. JBoss is working off a .WAR built from this directory.

      Is there any way to reference the unarchived files from Apache? Currently, they are going to c:\jboss-3.2.5\server\default\tmp\deploy\tmp17751xxx.war. I believe that the number is sequential so I can't depend on it.

      I guess what I'm asking is how to configure JBoss to deploy wars to a known location? I'd rather not have to manually unarchive the .WAR file into a deploy/filename.war/ directory (which I believe I read about in the FAQ?)

      Any help would be greatly appreciated.

      Thanks,
      Josh