0 Replies Latest reply on Sep 8, 2004 3:12 PM by siegy

    Using Jacorb 1.4.1 with JBoss 3.2.4

    siegy Newbie

      Hello, I hope someone can help me.

      Can one use two versions of Jacorb with one JBoss server?

      I am trying to deply a EJB using an application that requires Jacorb 1.4.1 with JBoss 3.2.4. It's java api is accessable through a jar file.

      This version of JBoss uses a newer version of Jacorb 1.4.1 that is incompatible with this application. Other applications served out by the JBoss server require this version of JBoss.

      I found that if I replaced the Jacorb.jar and Jacorb.properties files on my JBoss test box with the version 1.4.1 - the application worked. This solution is not acceptable on the production JBoss server.

      The application developers claim that the reverse solution is not possible -- using the newer version of Jacorb with this application. I tried to replace the jacorb files in their jar file and deploy it on JBoss and call it from my EJB. I got an exception:
      ____________________________________________________
      org.omg.CORBA.INITIALIZE: can't instantiate default ORB implementation org.jacorb.orb.ORB vmcid: 0x0 minor code: 0 completed: No
      at org.omg.CORBA.ORB.create_impl(Unknown Source)
      at org.omg.CORBA.ORB.init(Unknown Source)
      at com.engenium.semetric.TheORB.get(TheORB.java:16)
      at com.engenium.semetric.Engine.initRef(Engine.java:523)
      at com.engenium.semetric.Engine.getDocSet(Engine.java:81)
      at DOCADD.main(DOCADD.java:27)
      Caused by: java.lang.NoClassDefFoundError: org/apache/log/format/Formatter
      at java.lang.Class.getDeclaredConstructors0(Native Method)
      at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
      at java.lang.Class.getConstructor0(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at org.jacorb.util.Environment.initLogging(Unknown Source)
      at org.jacorb.util.Environment.init(Unknown Source)
      at org.jacorb.util.Environment.(Unknown Source)
      at org.jacorb.orb.BufferManager.(Unknown Source)
      at org.jacorb.orb.ORB.(Unknown Source)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      ... 6 more
      Exception in thread "main"
      ___________________________________________________
      I find it hard to believe that a library as heavily used as Jacorb would not be backwards compatible.