1 Reply Latest reply on Sep 21, 2004 1:04 AM by Scott Stark

    EJB spec complaince check in 3.2.5

    umesh bellur Newbie

      I am migrating from 3.0.0 to 3.2.5. My application contains a bunch of EJBs which now dont deploy with 3.2.5 because it complains about non complaince with EJB specifications. Specifically 3.2.5 complains that RemoteExceptions have not been declared for EJB methods. While I should fix this in the code I am wondering whether there is a way to force 3.2.5 to deploy bypassing this complaince check. It's urgent we get this up as soon as possible since it's a production application.

        • 1. Re: EJB spec complaince check in 3.2.5
          Scott Stark Master

          Edit the conf/jboss-service.xml file and set the VerifyDeployments attribute to false

           <!-- EJB deployer, remove to disable EJB behavior-->
           <mbean code="org.jboss.ejb.EJBDeployer" name="jboss.ejb:service=EJBDeployer">
           <attribute name="VerifyDeployments">true</attribute>
           <attribute name="ValidateDTDs">false</attribute>
           <attribute name="MetricsEnabled">false</attribute>
           <attribute name="VerifierVerbose">true</attribute>
          
           <!--
           StrictVerifier: Setting this to 'true' will cause all deployments
           to fail when the Verifier detected a problem with the contained
           Beans.
           -->
           <attribute name="StrictVerifier">true</attribute>
          
           <depends optional-attribute-name="TransactionManagerServiceName">jboss:ser
          vice=TransactionManager</depends>
           <depends optional-attribute-name="WebServiceName">jboss:service=WebService
          </depends>
           </mbean>